ODT defekt - Hilfe!

Das Textverarbeitungsprogramm

Moderator: Moderatoren

Hanni_85
Beiträge: 4
Registriert: Mi, 14.08.2013 13:45

ODT defekt - Hilfe!

Beitrag von Hanni_85 » Mi, 14.08.2013 14:19

Hallo Community!

Ich bin total verzweifelt, darum bitte ich euch um Hilfe.
Gleich vorweg: Ich bin ein totaler Depp und hatte das Häkchen bei Sicherungskopie erstellen NICHT gesetzt, genauso wie ich vorher noch nie was vom Dateiversionsverlauf bei win 8 gehört habe - Ergo: Es exsistiert keine .bak Datei! (bitte nicht mit mir schimpfen - ich weiß, dass ich Megascheisse gebaut habe, aber das hilft mir jetzt auch nix mehr)

Nun zum Problem:
Ich habe ein sehr wichtiges Dokument im odt-Format (erstellt mit OO 3.4.1), dass sich plötzlich nicht mehr öffnen lässt. Es gab keinen Systemabsturz oder Virus! Jedenfalls erscheint bei der letzten gespeicherten Version (vom 09.08.) beim öffnen immer die ACSII-Filter einstellung und es öffnen sich 30 Seiten nur Rauten. Nachdem ich mich schon stundenlang mit dieser Datei beschäftigt habe und schließlich in einem Hex-Editor nur Nullen vorgefunden habe, habe ich mich damit abgefunden, dass diese Datei futsch ist.

Sooo... Jetzt habe ich mit einem Shadow-Explorer meine Festplatte durchforstet und tatsächlich eine ältere Version (25.07.) gefunden. Gleich zu Anfang ist mir aufgefallen, dass dabei eine lock-file mit abgespeichert wurde. Ich habe beides rekonstruiert und schließlich versucht das alte odt mit OO zu öffnen : Dokument beschädigt...OO versucht zu reparieren... = es erscheint eine leere Seite.
Zumindest weiß ich, dass in der odt etwas enthalten sein muss, denn im notepad++ und im hex erscheinen Unmengen an "Hieroglyphen".
Nachdem ich nun seit zwei Tagen das Internet durchforste, habe ich schon diverse Dinge ausprobiert, um die Datei zu retten.
- das Ganze als Zip mit 7zip entpacken: Erst kann das Archiv nicht erkannt werden. Nach einem Zip-Repair kann ich es entpacken, aber die content.xml ist leer.
- Ich habe die neue OO-Version 4.0 heruntergeladen
- ich habe einen Registercleaner benutzt
- ich habe es mit Recuva versucht
- Ich habe versucht die Datei mit FileRepair zu retten
Hat alles nix gebracht!

Ich bin ja nun ein PC-Standard-Nutzer, das bedeutet, dass ich eigentlich keine Ahnung habe :-) Also: Ist denn die Datei noch irgendwie zu retten? Vor allem, da im Editor ja jede Menge Daten erscheinen, bin ich da noch voller Hoffnung. Oder ist das falsch? Puh, bitte helft mir, denn das Dokument beinhaltet ganze 100 Seiten Text, die mich mindestens 200 Arbeitsstunden und noch mehr Nerven gekostet haben, daher will ich jetzt nicht einfach aufgeben und versuchen wenigstens einen Teil des Ganzen zu retten. Formatierung ist mir dabei egal, mir geht es nur um den Text an sich!
Bitte helft mir!

Hanni

pmoegenb
********
Beiträge: 4330
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: ODT defekt - Hilfe!

Beitrag von pmoegenb » Mi, 14.08.2013 15:49

Hallo Hanni,
meiner Ansicht nach hast Du Alles getan, was man in diesem Fall tun kann. M. E. ist die Datei futsch.
Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

Benutzeravatar
Constructus
*******
Beiträge: 1611
Registriert: Mo, 21.01.2008 18:08
Wohnort: 20 Jahre Brilon - 40 Jahre Essen- Steele

Re: ODT defekt - Hilfe!

Beitrag von Constructus » Mi, 14.08.2013 17:50

Hanni_85 hat geschrieben: Gleich vorweg: Ich bin ein totaler Depp und hatte das Häkchen bei Sicherungskopie erstellen NICHT gesetzt, genauso wie ich vorher noch nie was vom Dateiversionsverlauf bei win 8 gehört habe - Ergo: Es exsistiert keine .bak Datei! (bitte nicht mit mir schimpfen - ich weiß, dass ich Megascheisse gebaut habe, aber das hilft mir jetzt auch nix mehr)
Hallo Hanni,

ja, Du dürftest Pech haben... Aber auch so ein Megacrash ergibt Lerneffekte... :mrgreen: Aber laß man stecken, totaler Depp und so... ich hab so einiges auch erst gelernt, als ich Mißerfolge hatte. Zwar läßt sich fast alles an Tipps zum Einsatz von Betriebssystemen, Officeprogrammen, Sicherungsverfahren etc, irgendwo finden- aber komme erst einmal darauf, vor Einsatz des Rechenknechts tagelang im Netz zu suchen... Ich gehe davon aus, daß oft Dokumentationen Mängel haben. Immerhin sehe ich aus Deiner Beschreibung, daß Du absolut nicht unwissend sein kannst. :D

Hast Du die Datei vor kurzem mal jemandem per Mail zugesendet? Könntest Du Dir davon eine Kopie zurückholen?
Ich kann mir kaum vorstellen, 200 Stunden aus dem Ärmel zu schütteln- hast Du Dokumente, aus denen Du Passagen geholt hast?
Hast Du eventuell das Konzept noch im Kopf, anhand dessen Du das Dokument verfaßt hast?

Ich bin zwar als MS- Basher tituliert, aber: benötigst Du unbedingt und zwingend das Kachel- MS? Könntest Du Dir vorstellen, eine Version tiefer zu steigen (MS 7)?
Wäre es Dir möglich, eine solche Maxiarbeit parallel mit "Speichern unter" auf einen Stick zu kopieren, z.B. einmal am Tag? Die interne Sicherung hilft nur insofern, als der gesamte Rechner immer mitspielt. Geht irgendwas gravierendes daran kaputt (Festplatte, Betriebssystem, Prozessor,...) ist oftmals sowieso alles weg,

Das hilft alles nicht zur Wiederherstellung der Originaldatei; aber wenn Du nochmal anfängst...

Viel Erfolg trotzdem

Constructus

P.s.: bevor Du irgendwelche Reparaturen oder Wiederherstellungsaktionen machst: versuche erst immer, mit dem Betriebssystem eine Kopie der Datei(en) zu machen und darin zu "spielen"- immerhin könnte jemand etwas wissen, was durch noch mehr Fehler erzeugende Reparaturen unnutzbar ist. :(
EDV ist wunderbar - o Wunder, wenn sie funktioniert! {°L*}

Freie Offices auf div. Linuxen + 3 VBoxen mit WIN2K
|| LibO + AOO, auf Linux und WIN2K; portable OO & Co. auf WIN
Genaue Typisierung unmöglich, alles ist "im Fluß"

Hanni_85
Beiträge: 4
Registriert: Mi, 14.08.2013 13:45

Re: ODT defekt - Hilfe!

Beitrag von Hanni_85 » Mi, 14.08.2013 18:44

Hey, danke schon mal für die schnellen Antworten!

@Peter: Oh nein...das wollte ich jetzt wirklich nicht hören :-)

@Constructus: Also, wenn du mit Kachel-Ms Windows 8 meinst, dann kann ich dir sagen, dass ich das nur verwende, weil das auf meinem neuen netbook vorinstalliert war. Auf meinem alten Notebook ist Win 7 drauf und ich muss schon sagen, dass mir das im ganzen Umgang viel besser gefällt (und die ganze Kacke da gar nicht erst passiert wäre).
Nunja,den Inhalt meines verloren gegangenen Dokuments habe ich mir tatsächlich "aus dem Ärmel geschüttelt". Es handelt sich nämlich dabei um einen Roman. Vorher habe ich mit Word von Mikrosoft gearbeitet, darum wusste ich bei Open auch nichts von dem "Sicherungshäkchen".
Nein, es gibt keinerlei Kopien, oder Anhänge, oder wasweißichwas, eben nur die Schattenkopien, die eben genauso beschädigt sind, wie die letzte Version meines odt.
Glaub mir - in Zukunft werde ich Sicherungskopien in stündlichem Abstand auf mind. einem Stick und meinem Notebook machen!

Aber ist denn da wirklich garnichts mehr zu machen? Würde da ein Dateiprofi vielleicht noch rankönnen? Kann man sich das als normalsterblicher überhaupt leisten???
Es ist wirklich zum Verzweifeln!

Hanni

pmoegenb
********
Beiträge: 4330
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: ODT defekt - Hilfe!

Beitrag von pmoegenb » Mi, 14.08.2013 18:58

Hallo Hanni,
Hanni_85 hat geschrieben: @Constructus:Also, wenn du mit Kachel-Ms Windows 8 meinst, dann kann ich dir sagen, dass ich das nur verwende, weil das auf meinem neuen netbook vorinstalliert war. Auf meinem alten Notebook ist Win 7 drauf und ich muss schon sagen, dass mir das im ganzen Umgang viel besser gefällt (und die ganze Kacke da gar nicht erst passiert wäre).
Na, da wirst Du Dich aber freuen, wenn Du dieses Jahr, ab 17. Oktober, Windows 8.1 (mit Startbutton) kostenlos von Microsoft herunter laden darfst.

Bis es soweit ist kannst Du entweder ClassicShell oder 8StartButton installieren.
Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

Hanni_85
Beiträge: 4
Registriert: Mi, 14.08.2013 13:45

Re: ODT defekt - Hilfe!

Beitrag von Hanni_85 » Fr, 16.08.2013 10:36

Hallo Zusammen!

Ich bin immer noch verzweifelt und möchte immer noch nicht aufgeben, darum habe ich jetzt einfach mal die Datei angehängt und bitte euch darum, mal einen Blick drauf zuwerfen. Wenn mir dann zehn Leute sagen, dass es hoffnungslos ist, werde ich 5 Tage lang in tiefe Depressionen fallen und mich danach damit abfinden das Ganze nochmal neu zu schreiben...

lg
Hanna

PS: Also, das mit dem Start-Button ist ja wohl echt ein Witz. Was haben sich die schlauen Leute bei der Entwicklung eigentlich dabei gedacht, dass ich eines der wichtigsten Tools, der noch dazu einen der wichtigsten Wiedererkennungswerte darstellt, einfach zu entfernen? Kapier ich nicht. Aber naja...
Dateianhänge
Kapitel 1.odt
Schattenkopie
(96.17 KiB) 116-mal heruntergeladen

pmoegenb
********
Beiträge: 4330
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: ODT defekt - Hilfe!

Beitrag von pmoegenb » Fr, 16.08.2013 11:05

Hallo Hanni,
Hanni_85 hat geschrieben: PS: Also, das mit dem Start-Button ist ja wohl echt ein Witz. Was haben sich die schlauen Leute bei der Entwicklung eigentlich dabei gedacht, dass ich eines der wichtigsten Tools, der noch dazu einen der wichtigsten Wiedererkennungswerte darstellt, einfach zu entfernen? Kapier ich nicht. Aber naja...
Na ja, Microsoft war der Auffassung der PC-Branche einen Boom verschaffen zu müssen, in dem sich alle Anwender Touchscreens anschaffen. Wie wir aber alle jetzt wissen, ging das in die Hose.
Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

hol.sten
******
Beiträge: 871
Registriert: Fr, 18.11.2005 21:21

Re: ODT defekt - Hilfe!

Beitrag von hol.sten » Fr, 16.08.2013 20:32

Hanni_85 hat geschrieben:habe ich jetzt einfach mal die Datei angehängt und bitte euch darum, mal einen Blick drauf zuwerfen.
Habe ich getan. Da ist nix zu machen. Der Inhalt ist weg.

Schaut man sich die Datei mit einem Hex-Editor an, sieht man, dass da ein paar Bytes mit Werten > 0 drin stehen, die sind aber leider in der Minderheit. Statt dessen gibt es sehr viele Bytes mit dem Wert 0, deren Informationsgehalt im Allgemeinen nicht sehr hoch ist. Nach dem Betrachten mit dem Hex-Editor hatte ich daher schon kaum noch Hoffnung.

Als nächstes habe ich die Datei mehrfach von der Commandline mit zip -FF bearbeitet. Das erzeugte folgende Ausgaben:
Zuerst:

Code: Alles auswählen

$ zip -FF Kapitel\ 1.odt --out fix.zip
Fix archive (-FF) - salvage what can
 Found end record (EOCDR) - says expect single disk archive
Scanning for entries...
 copying: mimetype  (39 bytes)
 copying: Configurations2/statusbar/  (0 bytes)
 copying: Configurations2/accelerator/current.xml  (2 bytes)
 copying: Configurations2/floater/  (0 bytes)
 copying: Configurations2/popupmenu/  (0 bytes)
 copying: Configurations2/progressbar/  (0 bytes)
 copying: Configurations2/toolpanel/  (0 bytes)
 copying: Configurations2/menubar/  (0 bytes)
 copying: Configurations2/toolbar/  (0 bytes)
 copying: Configurations2/images/Bitmaps/  (0 bytes)
 copying: layout-cache  (262 bytes)
 copying: content.xml 
	zip warning: no end of stream entry found: content.xml
	zip warning: rewinding and scanning for later entries
content.xml ist also beschädigt, weil nur teilweise im Archiv drin. Nach dem was der Hex-Editor zeigt, wenn überhaupt ein paar Zeilen, mehr nicht.
Und dann:

Code: Alles auswählen

$ zip -FF fix.zip --out fixfix.zip
Fix archive (-FF) - salvage what can
 Found end record (EOCDR) - says expect single disk archive
Scanning for entries...
 copying: mimetype  (39 bytes)
 copying: Configurations2/statusbar/  (0 bytes)
 copying: Configurations2/accelerator/current.xml  (2 bytes)
 copying: Configurations2/floater/  (0 bytes)
 copying: Configurations2/popupmenu/  (0 bytes)
 copying: Configurations2/progressbar/  (0 bytes)
 copying: Configurations2/toolpanel/  (0 bytes)
 copying: Configurations2/menubar/  (0 bytes)
 copying: Configurations2/toolbar/  (0 bytes)
 copying: Configurations2/images/Bitmaps/  (0 bytes)
 copying: layout-cache  (262 bytes)
Central Directory found...
EOCDR found ( 1   1707)...
no local entry: settings.xml
no local entry: META-INF/manifest.xml
EOCDR found ( 1  98461)...
Insgesamt kann man so aus dem kaputten Archiv drei Dateien extrahieren (layout-cache (262 bytes), mimetype (39 bytes), Configurations2/accelerator/current.xml (2 bytes)), die nichts wirklich brauchbares enthalten. Von content.xml habe ich nichts retten können.

Hanni_85
Beiträge: 4
Registriert: Mi, 14.08.2013 13:45

Re: ODT defekt - Hilfe!

Beitrag von Hanni_85 » Fr, 16.08.2013 23:00

Hi!

Vielen Dank für deine Mühe!

Mann mann mann... naja, langsam finde ich mich mit meinem Schicksal ab. Nur verstehen kann ich es immer noch nicht ganz.
Was ist passiert??? Die Datei, die ich angehängt habe, ist vom 25.07. Ich habe auch danach jeden Tag an dem Dokument gearbeitet und es gab nie Probleme! Am 10.08. möchte ich das Dokument öffnen und dann erscheint dieser ASCII-Filter... sehr mysteriös das Ganze und ehrlich gesagt ist mein Vertrauen in OO ziemlich erschüttert.

Zumindest habe ich daraus gelernt. Ich habe alle Sicherungen aktiviert, die ich finden konnte, speichere auf USB und auf mein zweites Notebook und werde zusätzlich regelmäßig als Anhang eine E-Mail an meine Freundin senden. Ich denke, dass sollte dann wohl reichen.

Danke nochmal!

Hanna

Sabsi
Beiträge: 1
Registriert: So, 22.12.2013 00:03

Re: ODT defekt - Hilfe!

Beitrag von Sabsi » So, 22.12.2013 00:32

Hallo,
da ich ebenfalls ein Problem mit einem defekten odt.-Dokument habe, schildere ich es hier, hoffe das ist ok.

Ein mehr als 1000 Seiten umfassendes, sehr persönliches Text-Dokument lässt sich mit open office (4.0.0; allerdings mit einer Vorgängerversion erstellt) nicht mehr öffnen. Der Vorschlag, die Datei zu reparieren wird nach meiner Bestätigung mit einer leeren Seite quittiert.

Nachdem ich selbst alles mir Mögliche versucht habe (zip, Editor, xml/ html; - es werden nur Hieroglyphen angezeigt; Fehlermeldungen, dass der Dateikopf beschädigt sei, etc.; Recovery,) stellte ich mittels verschiedener Repair/ Recovery-Programme fest, dass der Text (aus der content.xml) an einer Stelle abgeschnitten und ab dieser mehrfach wiederholt wird und dann abrupt endet, wofür mir bislang niemand einen Grund und auch keine Lösung nennen konnte.

Ein örtlicher Fachmann wusste keinen Rat, eine weitere Person verknüpfte den erwähnten abgeschnittenen Text mit der style.xml. Ein in dem fehlenden Text eingebundenes Image-File wurde extrahiert.

Bei den ausprobierten Repair-Programmen wird das Problem angezeigt, keine Daten oder keine Datenquelle finden zu können.

Habt Ihr eine Idee, ob es eine Möglichkeit gibt, den vollständigen Text wiederherzustellen? Eine Sicherungsdatei existiert leider nicht. Das Häkchen habe ich nachträglich gesetzt.

Da es sich um ein sehr intimes Dokument handelt, möchte ich es möglichst nicht hochladen oder verschicken, hoffe aber, dass mir jemand einen Rat geben kann.

mfG
Sabsi

pmoegenb
********
Beiträge: 4330
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: ODT defekt - Hilfe!

Beitrag von pmoegenb » So, 22.12.2013 14:38

Dir Hoffnung stirbst zuletzt, aber in dem Thread wurde bereits Alles angegeben, was es in diesem Zusammenhang anzugeben gibt.
Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

Antworten