Java unter Opensuse angeblich defekt

spezielle Probleme mit AOO/LO unter Linux

Moderator: Moderatoren

ortenau-s-bahner
***
Beiträge: 61
Registriert: Mi, 30.06.2004 09:12

Java unter Opensuse angeblich defekt

Beitrag von ortenau-s-bahner » Do, 11.10.2007 16:23

Hi,

wenn ich mit meinem OOo 2.3 unter Linux etwas machen will, was Java benötigt (bspw. der Formular-Assistent in Base) kommt die Fehlermeldung, die ausgewählte Java-Laufzeitumgebung (JRE) sei defekt.
Im entsprechenden Dialog in den Optionen kann ich wählen zwischen der Original JRE von Sun (Version 1.5.0_12) und einem weiteren Eintrag der Free Software Foundation (Version 1.4.2). Egal welchen Eintrag ich hier auswähle (Sun verlangt jedes Mal einen Neustart von OOo), die Fehlermeldung jedesmal immer wieder.
Java ist aber ansonsten im System offenbar korrekt installiert (über YaST), auch andere Programme, die es benötigen funktionieren; bspw. JFTP.
Muss ich evt. unter Parameter oder ClassPath noch etwas eintragen, damit ich Java auch unter OOo nutzen kann? Oder woran könnte es sonst noch liegen?

TIA

ortenau-s-bahner
***
Beiträge: 61
Registriert: Mi, 30.06.2004 09:12

Re: Java unter Opensuse angeblich defekt

Beitrag von ortenau-s-bahner » Fr, 12.10.2007 16:06

Hat sich erledigt, Problem gelöst.
Nachdem ich das hier gelesen hatte, habe ich mal die Datei ~/.ooo-2.0/user/config/javasettings_Linux_x86.xml aus dem Verkehr gezogen, in der noch der Pfad zur JRE 1.4.nochwas vermerkt war. Beim Neustart von OOo wurde sie offenbar wieder korrekt angelegt und seitdem funktioniert alles. :)

Hokey

Re: Java unter Opensuse angeblich defekt

Beitrag von Hokey » Fr, 28.03.2008 10:17

Danke! Das hat mir gerade beim Upodate auf 2.4 in Kubuntu Gutsy ebenfalls geholfen!

Antworten