Absturz durch Scanauftrag

spezielle Probleme mit AOO/LO unter Linux

Moderator: Moderatoren

Benutzeravatar
Constructus
*******
Beiträge: 1611
Registriert: Mo, 21.01.2008 18:08
Wohnort: 20 Jahre Brilon - 40 Jahre Essen- Steele

Absturz durch Scanauftrag

Beitrag von Constructus » Fr, 24.06.2011 19:15

Hallo zusammen (besonders die openSUSE- Kenner...),

seit einem Update habe ich das Problem, daß beim Versuch, einen Scan direkt aus z.B. Writer zu sterten, das LibreOffice sofort abstürzt, und zwar gänzlich (d.h, auch nicht betroffene offene Dokumente sind weg).

Ich versuche das auf diese Weise: Einfügen- Bild- Scannen- Quelle auswählen- und alles ist weg. Bis zum Update vor ca. 2 Wochen ging das noch einwandfrei...

Hat jemand anders das gleiche Problem schon mal gehabt? Bei anderen Programmen funktioniert das aber weiterhin; nur ist es lästig, ein Bild erst im Gimp einzuscannen und nach LO zu kopieren...

Schönes Wochenende

Constructus
EDV ist wunderbar - o Wunder, wenn sie funktioniert! {°L*}

Freie Offices auf div. Linuxen + 3 VBoxen mit WIN2K
|| LibO + AOO, auf Linux und WIN2K; portable OO & Co. auf WIN
Genaue Typisierung unmöglich, alles ist "im Fluß"

Benutzeravatar
komma4
********
Beiträge: 5323
Registriert: Mi, 03.05.2006 23:29
Wohnort: Chon Buri Thailand Asia
Kontaktdaten:

Re: Absturz durch Scanauftrag

Beitrag von komma4 » Fr, 24.06.2011 20:32

Constructus hat geschrieben:seit einem Update
Update - von was?

xsane funktioniert anscheinend ja noch - probiere mal ein frisches OOo-Benutzerverzeichnis (altes sichern, löschen)
Cheers
Winfried
aktuell: LO 5.2.5.1 20m0(Build:1) unter Linux openSuSE Leap 42.3 x86_64/KDE5
DateTime2 Einfügen von Datum/Zeit/Zeitstempel (als OOo Extension)

Benutzeravatar
Constructus
*******
Beiträge: 1611
Registriert: Mo, 21.01.2008 18:08
Wohnort: 20 Jahre Brilon - 40 Jahre Essen- Steele

Re: Absturz durch Scanauftrag

Beitrag von Constructus » Sa, 25.06.2011 00:33

komma4 hat geschrieben: Update - von was?

xsane funktioniert anscheinend ja noch - probiere mal ein frisches OOo-Benutzerverzeichnis (altes sichern, löschen)
Oha, Systemupdate natürlich (zypper dup). Da ich LO aus den openSUSE- Quellen installiert habe (von Anfang an), wird das jedesmal bei Neuerungen mit upgedatet.

Jetzt erwischt es mich wohl auch mal mit dem Reparaturstandard... Benutzerverzeichnis. Wahrscheinlich ist umbenennen erste Wahl, weil ich das dann eigentlich nicht selbsttätig sichern muß. Jedenfalls kann ich dann gewisse Eigeneinbauten herüberkopieren, wie z.B. die Dokumentvorlagen.

Ich melde mich, wenn's damit geklappt hat

Danke & schönes Wochenende

Constructus
EDV ist wunderbar - o Wunder, wenn sie funktioniert! {°L*}

Freie Offices auf div. Linuxen + 3 VBoxen mit WIN2K
|| LibO + AOO, auf Linux und WIN2K; portable OO & Co. auf WIN
Genaue Typisierung unmöglich, alles ist "im Fluß"

Eddy
********
Beiträge: 2490
Registriert: So, 02.10.2005 10:14

Re: Absturz durch Scanauftrag

Beitrag von Eddy » Sa, 25.06.2011 14:13

Hallo Constructus,

das Scan-Problem kann ich unter 0penSuse 11.4 so bestätigen. Unter 11.3 hats noch funktioniert.

Mit ungescannten Grüßen

Eddy

Benutzeravatar
Constructus
*******
Beiträge: 1611
Registriert: Mo, 21.01.2008 18:08
Wohnort: 20 Jahre Brilon - 40 Jahre Essen- Steele

Re: Absturz durch Scanauftrag

Beitrag von Constructus » Sa, 25.06.2011 18:33

Eddy hat geschrieben:...
das Scan-Problem kann ich unter 0penSuse 11.4 so bestätigen. Unter 11.3 hats noch funktioniert.
Hallo Eddy,

danke für den Hinweis. Ich werde nachher mein Zweitsystem noch mal starten und das auch da probieren. Die 11.4 dort ist ziemlich zu Anfang nur 1 x upgedatet. Geht es dort noch, muß der Bock erst später aufgetreten sein.

Unabhängig davon ist das testweise Umbenennen des Benutzerverzeichnisses auch ein Weg; hat das keine Auswirkungen, sollte das Zurückbenennen sicher den jetzigen Zustand wiederbringen.

Bei mir hat das Verzeichnis jetzt den Pfad /home/User_1/.libreoffice/3-suse/user, wobei ich mir jetzt nicht sicher bin, an welcher Stelle ich die Umbenennung ausführe; vielleicht fange ich da von hinten an, also z.B. .../Ruser für Reserve- User...

Nette Grüße

Constructus

P.s.: ich ergänze mal: die gleichen Versuche unter einer LO 3.3.2.2 auf einer LXDE- Oberfläche unter openSUSE 11.4 sowie mit einer 3.3.3.1 unter XFCE hatten das gleiche (Absturz-) Ergebnis.
EDV ist wunderbar - o Wunder, wenn sie funktioniert! {°L*}

Freie Offices auf div. Linuxen + 3 VBoxen mit WIN2K
|| LibO + AOO, auf Linux und WIN2K; portable OO & Co. auf WIN
Genaue Typisierung unmöglich, alles ist "im Fluß"

eichhofener
Beiträge: 1
Registriert: So, 22.01.2012 20:39

Re: Absturz durch Scanauftrag

Beitrag von eichhofener » So, 22.01.2012 20:44

Gibt es denn hierzu etwas neues?
Ich benutze einen Epson Perfection V200 unter OpenSuse 11.4 und LibreOffice 3.4.2
Auch bei mir stürzt LibreOffice sofort ab.
Vielen Dank
lg
eichhofener

Benutzeravatar
Constructus
*******
Beiträge: 1611
Registriert: Mo, 21.01.2008 18:08
Wohnort: 20 Jahre Brilon - 40 Jahre Essen- Steele

Re: Absturz durch Scanauftrag

Beitrag von Constructus » Mo, 23.01.2012 00:15

eichhofener hat geschrieben:Gibt es denn hierzu etwas neues?
Ich benutze einen Epson Perfection V200 unter OpenSuse 11.4 und LibreOffice 3.4.2
Auch bei mir stürzt LibreOffice sofort ab.
Hallo eichhofener,

das hat vielleicht weniger mit dem Scanner, sondern mit dem Betriebssystem zu tun. Die Verbindung LO / XSane oder Scanlite unter Linux könnte auch Schwächen haben. Ich hab mich nicht weiter mit dem Thema beschäftigt, weil ich jetzt direkt unter einem der beiden Werkzeuge scanne und das Ergebnis nach LO kopiere. Vielleicht wäre es besser, wenn man mal nach den Einstellung schaute; ich hab gerade nur keine Zeit dazu.

Nette Grüße

Constructus
EDV ist wunderbar - o Wunder, wenn sie funktioniert! {°L*}

Freie Offices auf div. Linuxen + 3 VBoxen mit WIN2K
|| LibO + AOO, auf Linux und WIN2K; portable OO & Co. auf WIN
Genaue Typisierung unmöglich, alles ist "im Fluß"

mh11
Beiträge: 5
Registriert: Di, 28.02.2012 22:40

Re: Absturz durch Scanauftrag

Beitrag von mh11 » Di, 28.02.2012 22:46

Hallo zusammen,

schon jemand Erfolg mit dem LO gehabt?

Ich habe dasselbe Problem mit einem Brother DCP-195C Multifunktionsgerät und den (jeweils aktuell gehaltenen)
Versionen von SuSE 11.4/64 und 12.2/64.

Diesbzgl. habe ich einen Bug-Report gemeldet
https://bugzilla.novell.com/show_bug.cgi?id=747233

der auch bearbeitet wird, aber eben (noch) nicht geloest ist.

Vielleicht ist ja hier jemand schneller? ;-)

Benutzeravatar
Constructus
*******
Beiträge: 1611
Registriert: Mo, 21.01.2008 18:08
Wohnort: 20 Jahre Brilon - 40 Jahre Essen- Steele

Re: Absturz durch Scanauftrag

Beitrag von Constructus » Mi, 29.02.2012 16:13

Hallo mh11,

Dein Bugreport ist sicher hilfreich; aber: irgendetwas liegt bei LO mehr grundsätzlich im argen.

Nicht nur in diesem Forum ist die Meinung zu LO mittlerweile gespalten. Ich weiß nicht, wie weit OO gerade ist; liegt eine fertige Version vor, melde ich die repos von openSUSE zu LO ab, lösche LO, benenne das Nutzerverzeichnis um und installiere ein neues OO. Sollten dann solche Fehler wie in diesem Thread nicht mehr vorhanden sein, bliebe ich beim aktuellen OO; sonst würde ich ein älteres OO oder LO wieder installieren und benutzen.

Auch bei verschiedenen Linux- Distris nimmt die Community- Fixiertheit immer mehr zu, was der Anwender wirklich will, interessiert kaum jemanden. Schade drum.

Nette Grüße

Constructus
EDV ist wunderbar - o Wunder, wenn sie funktioniert! {°L*}

Freie Offices auf div. Linuxen + 3 VBoxen mit WIN2K
|| LibO + AOO, auf Linux und WIN2K; portable OO & Co. auf WIN
Genaue Typisierung unmöglich, alles ist "im Fluß"

mh11
Beiträge: 5
Registriert: Di, 28.02.2012 22:40

Re: Absturz durch Scanauftrag

Beitrag von mh11 » Do, 08.03.2012 22:26

Hallo Contructus,

sorry fuer die spaete Antwort, die Mailbenachrichtung ist irgendwie in den Evolution "unerwuenscht" Ordner verschwunden :-(

Na ja, die OO statt LO Loesung ist vielleicht eine Moeglichkeit, das Problem zu "work-arounden", ich persoenlich tendiere aber
(sorry, jetzt wird´s OT) SuSE zu verlassen und eine andere Distro zu nehmen.

Das LO Prob ist naemlich nicht das Einzige seit SuSE 11.3

Mit 11.4 funktioniert die PalmSync in Evolution (gnome-pilot) wegen fehlendem evolution-pilot Paket nicht mehr,
seit 12.1 geht die Rabbit-VCS nicht mehr, weil die Pakete nicht angeboten werden.

Ganz zu schweigen vom unsaeglichen Gnome 3, das den User bewusst einschraenkt, etc...

Schade eigentlich, dass die Communities sich so wenig an der "Usability" orientieren, sondern immer was Neues machen wollen, auch wenn es schlechter ist, als das Gewesene.

Oder kurz: ich will mein 11.3 zurueck ;-)

BTW: ich sehe gerade ich hatte mich vertippt, ich meinte natuerlich 12.1, nicht 12.2 (das "damals" nicht mal als Milestone verfuegbar war)

Benutzeravatar
Constructus
*******
Beiträge: 1611
Registriert: Mo, 21.01.2008 18:08
Wohnort: 20 Jahre Brilon - 40 Jahre Essen- Steele

Re: Absturz durch Scanauftrag

Beitrag von Constructus » Fr, 09.03.2012 00:28

mh11 hat geschrieben: sorry fuer die spaete Antwort, die Mailbenachrichtung ist irgendwie in den Evolution "unerwuenscht" Ordner verschwunden :-(
Hallo mb11,

erforderlich ist eine schnelle Antwort nicht, nur einfach nett.
mh11 hat geschrieben:Na ja, die OO statt LO Loesung ist vielleicht eine Moeglichkeit, das Problem zu "work-arounden", ich persoenlich tendiere aber
(sorry, jetzt wird´s OT) SuSE zu verlassen und eine andere Distro zu nehmen.
Du bist jetzt einer der wenigen, die größere Mißstände bei openSUSE bestätigen. Ich selbst sitze am Rechner und versuche immer zu ermitteln, ob ich mal wieder die falsche Tast gedrückt habe oder sonstwas... Immerhin möglich ist bei Problemen allein mit den Offices, die aus den Repos zu entfernen und die aus den Originalquellen zu installieren. Oder eben der Wechsel LO <> OO. Ich habe ja die Möglichkeit, die Officevariante auf Mageia zu testen oder die auf einem testmäßigen oS 12.1 KDE. Auf Mageia sind weniger Mängel; die 12.1 habe ich noch nicht näher probiert, weil ich da einfach keine Lust habe, schon wieder den Zirkus mit den Brother- MFG- Treibern durchzuziehen.
mh11 hat geschrieben:Das LO Prob ist naemlich nicht das Einzige seit SuSE 11.3

Mit 11.4 funktioniert die PalmSync in Evolution (gnome-pilot) wegen fehlendem evolution-pilot Paket nicht mehr,
seit 12.1 geht die Rabbit-VCS nicht mehr, weil die Pakete nicht angeboten werden.

Ganz zu schweigen vom unsaeglichen Gnome 3, das den User bewusst einschraenkt, etc...
Ich sehe mir oft irgendwelche Gnome- Varianten an auf Livesystemen; immer wieder bin ich froh, KDE wieder zu nutzen. Ist halt Gewohnheit...
mh11 hat geschrieben:Schade eigentlich, dass die Communities sich so wenig an der "Usability" orientieren, sondern immer was Neues machen wollen, auch wenn es schlechter ist, als das Gewesene.

Oder kurz: ich will mein 11.3 zurueck ;-)

BTW: ich sehe gerade ich hatte mich vertippt, ich meinte natuerlich 12.1, nicht 12.2 (das "damals" nicht mal als Milestone verfuegbar war)
Die 11.3 hab ich garnicht verwendet; von der 11.2 auf die 11.4 und jetzt testweise die 12.1. Aber die kommt nicht ins Hauptsystem. Anwenderfreundlich ist die Susie in der Regel schon; nur können Experten über gewisse Mängel nicht hinwegsehen. Mir liegt das Bedienkonzept der deb- Systeme nicht besonders, aber z.B. Mageia als Abkömmling von Mandriva ist einigermaßen akzeptabel (rpm). Die Kombination von YaST und zypper ist für mich schwer zu schlagen; das macht einige andere Macken wieder wett.

Die Viellfalt ist eigentlich auch der größte Fehler von Linux. versucht man oft etwas neues, weiß man hinterher überhaupt nicht mehr, wo die Glocken hängen. Zur Communitysierung gibt es wachsende Kritik, nur weiß niemand, wie es ohne ginge.
Ich bin manchmal geneigt, ein gut laufendes System mit der Linuxbasis, der OO- oder LO- Version, einigen Zeichenprogrammen, den Druckereinstellungen und der Virtualbox auf einer separaten Festplatte zu archivieren, um etwas Fuktionelles zu haben; nur muß das bei der INet- Räuberhöhle dann nach Beendigung des Supports aus dem Netz bleiben.

Aber genug gelästert, interessant ist auch hier im Forum, mit welchen Problemen sich andere Nutzer herumschlagen müssen. Nicht aus Schadenfreude, sondern aus Wißbegier.

Schönes Wochenende

Constructus
EDV ist wunderbar - o Wunder, wenn sie funktioniert! {°L*}

Freie Offices auf div. Linuxen + 3 VBoxen mit WIN2K
|| LibO + AOO, auf Linux und WIN2K; portable OO & Co. auf WIN
Genaue Typisierung unmöglich, alles ist "im Fluß"

mh11
Beiträge: 5
Registriert: Di, 28.02.2012 22:40

Re: Absturz durch Scanauftrag

Beitrag von mh11 » Mi, 04.04.2012 19:46

Hallo (mal wieder;-))

beim von mir genannten Bugreport
https://bugzilla.novell.com/show_bug.cgi?id=747233
geht es ein bisschen weiter.

Der Crash passiert in meinem Fall im Treiber des Brother-Treibers,
weshalb die SuSE Experten nun sagen:
"Liegt nicht an LO, Sane oder sonst was, sondern am Brother Treiber".

Ich sehe das anders, schreibt doch schon "eichenhofener" von einem
"Epson Perfection V200".

Deshalb nun die Frage an all' die anderen, welche Scanner denn benutzt werden.

Vielleicht kann "den SuSEs" bewiesen werden, dass es eben nicht am Treiber liegt.

Benutzeravatar
Constructus
*******
Beiträge: 1611
Registriert: Mo, 21.01.2008 18:08
Wohnort: 20 Jahre Brilon - 40 Jahre Essen- Steele

Re: Absturz durch Scanauftrag

Beitrag von Constructus » Mi, 04.04.2012 21:19

mh11 hat geschrieben: Der Crash passiert in meinem Fall im Treiber des Brother-Treibers,
weshalb die SuSE Experten nun sagen:
"Liegt nicht an LO, Sane oder sonst was, sondern am Brother Treiber".

Deshalb nun die Frage an all' die anderen, welche Scanner denn benutzt werden.
Vielleicht kann "den SuSEs" bewiesen werden, dass es eben nicht am Treiber liegt.
Hallo mh11,

die Wahrscheinlichkeit, daß es doch an openSUSE liegt, ich recht hoch. Ich betreibe einen Brother DCP 165C, die Treiber stammen auch von Brother:

Code: Alles auswählen

/brscan-skey-0.2.1-3.x86_64.rpm
/brscan3-0.2.11-4.x86_64.rpm
/dcp165ccupswrapper-1.1.2-2.i386.rpm
/dcp165clpr-1.1.2-2.i386.rpm
Unter Mageia arbeitet das Gerät, auch mit Brothertreibern, aber einwandfrei. Auf der 12.1 habe ich mich noch nicht drum gekümmert, weil die Version sowieso nicht mackenfrei läuft.

P.s.: Nachtrag: die Treiber im Mageia

Code: Alles auswählen

/brscan-skey-0.2.1-3.x86_64.rpm
/brscan3-0.2.11-4.x86_64.rpm
/dcp165ccupswrapper-1.1.2-2.i386.rpm
/dcp165clpr-1.1.2-2.i386.rpm
Sind wohl die gleichen. Wie gesagt, dort gibt es die beschriebenen Fehler nicht-

Also gib den Susies ruhig mal einen Nasenstüber... vielleicht wird das System dann auch mal mackenfreier. :(

Nette Grüße

Constructus
EDV ist wunderbar - o Wunder, wenn sie funktioniert! {°L*}

Freie Offices auf div. Linuxen + 3 VBoxen mit WIN2K
|| LibO + AOO, auf Linux und WIN2K; portable OO & Co. auf WIN
Genaue Typisierung unmöglich, alles ist "im Fluß"

mh11
Beiträge: 5
Registriert: Di, 28.02.2012 22:40

Re: Absturz durch Scanauftrag

Beitrag von mh11 » Do, 05.04.2012 12:01

Na also, die "SuSE's" haben hier:

https://bugzilla.novell.com/show_bug.cgi?id=747233

den Bug akzeptiert (auch fuer nicht-Brother Scanner)

<Quote>
Because I have an openSUSE 11.4 system and - voila ! - I can
reproduce it there with my Canon CanoScan N1240U/LiDE30
(using the SANE driver "plustek"):
</>

mal schauen, wie es weiter geht... Das nur als Zwischenstand.

Ich werde hier aber nicht weiter berichten (nicht aus Boesartigkeit, sondern wegen "single-source")
und verweise einfach nur noch auf o.g. Bugzilla-Link.

Benutzeravatar
Constructus
*******
Beiträge: 1611
Registriert: Mo, 21.01.2008 18:08
Wohnort: 20 Jahre Brilon - 40 Jahre Essen- Steele

Re: Absturz durch Scanauftrag

Beitrag von Constructus » Do, 05.04.2012 19:12

Hallo mb11,

ich hab's grad noch einmal getestet- immer noch Absturz beim Versuch, irgendetwas per Scanner in LO einzufügen. Also keine Änderung trotzt mehrerer Updates und Upgrades bei LO. Ob ich noch einmal versuche, die Brothertreiber auf dem USB- System mit openSUSE 12.1 nachzuinstallieren, kann ich noch nicht abschätzen. Ich schiebe die Änderung der Installation immer noch vor mir her, weil ich gehofft hatte, irgendein Update könnte den Fehler beheben/ behoben haben. Andere Arbeiten am Rechner haben sowieso höhere Priorität, weil ja zumindest die Installation auf Mageia die Probleme nicht hat.

Ich fände es aber nett, wenn Du hier berichten würdest, wenn Deine Bugmeldung Erfolg hatte. LO und openSUSE sind - zumindest bei mir - derzeit kein Erfolgsgespann.

Nette Grüße

Constructus
EDV ist wunderbar - o Wunder, wenn sie funktioniert! {°L*}

Freie Offices auf div. Linuxen + 3 VBoxen mit WIN2K
|| LibO + AOO, auf Linux und WIN2K; portable OO & Co. auf WIN
Genaue Typisierung unmöglich, alles ist "im Fluß"

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste