OO3.3 portable stürzt beim Start ab

AOO/LO für die Hosentasche (USB-Stick)

Moderator: Moderatoren

midas
*
Beiträge: 17
Registriert: Mo, 08.03.2010 15:01

OO3.3 portable stürzt beim Start ab

Beitrag von midas » Mo, 07.05.2012 01:52

Hallo,

Leider stürzt OOPortable 3.3 (nach dieser Anleitung gebaut) beim Starten ab. Es kommt direkt die Windows Fehlermeldung "OpenOffice 3.3 funktioniert nicht mehr. Es wird nach einer Lösung gesucht."
Da es mein erster Versuch ist OO portabel zu installieren, bin ich nun etwas ratlos.
'Bitte um Hilfe. Danke.

Gast

Re: OO3.3 portable stürzt beim Start ab

Beitrag von Gast » Mo, 07.05.2012 08:43

spontane Vermutung:
- Im Pfad sind Sonderzeichen oder Leerzeichen.

Oder bootstrap.ini wurde fehlerhaft angepasst. Öffne sie mit dem Editor und kopiere den Inhalt hier rein.

midas
*
Beiträge: 17
Registriert: Mo, 08.03.2010 15:01

Re: OO3.3 portable stürzt beim Start ab

Beitrag von midas » Fr, 11.05.2012 21:30

Die bootstrap.ini ist genauso wie angegeben, außer dass da Openoffice anstelle von LibreOffice steht.
Der Pfad ist auf dem Desktop, eigentlich ist dieser ohne Leer-/Sonderzeichen bei Win7 C:\Users\...

f

Re: OO3.3 portable stürzt beim Start ab

Beitrag von f » Fr, 11.05.2012 22:24

Der Pfad ist auf dem Desktop, eigentlich ist dieser ohne Leer-/Sonderzeichen bei Win7 C:\Users\...
Wir können leider nicht auf deinen Desktop schauen.

Installiert ist OO sicher nicht auf dem Desktop.
Schau dir den Pfad im Verzeichnis, wo das installiert ist - und poste ihn hier.
Die bootstrap.ini ist genauso wie angegeben, außer dass da Openoffice anstelle von LibreOffice steht.
Man kann aber aus Versehen einen kleinen aber entscheidenden Fehler machen.

Poste doch den Eintrag aus der bootstrap.ini, kopiere ihn einfach hier rein.

Wenn du aber meinst, dass beides 100%ig fehlerfrei ist (?)
dann hilft es vielleicht das Benutzerverzeichnis umzubenennen.

midas
*
Beiträge: 17
Registriert: Mo, 08.03.2010 15:01

Re: OO3.3 portable stürzt beim Start ab

Beitrag von midas » Sa, 12.05.2012 18:52

Hi,
Der genaue Pfad ist: C:\Users\Midas\Desktop\TestportOO
Midas hat 5 Buchstaben, keine Sonderzeichen und alle 5 stammen aus den 26 Buchstaben des lateinischen Alphabetes.
Die bootsrap.ini ist:

Code: Alles auswählen

[Bootstrap]
BaseInstallation=${OOO_BASE_DIR}
InstallMode=<installmode>
ProductKey=OpenOffice.org 3.3
UserInstallation=$ORIGIN/../Data/settings
[ErrorReport]
ErrorReportPort=80
ErrorReportServer=
.../Data/settings enthält eine .lock-Datei

eerm... Benutzerverzeichnis umbenennen? Das von OO? Könntest du etwas präziser sein? Danke schon mal.

f

Re: OO3.3 portable stürzt beim Start ab

Beitrag von f » Sa, 12.05.2012 19:40

Der genaue Pfad ist: C:\Users\Midas\Desktop\TestportOO
Du hast tatsächlich OOo auf dem Desktop installiert (und nicht nur die Verknüpfung abgelegt).
.../Data/settings[...]
eerm... Benutzerverzeichnis umbenennen? Das von OO? Könntest du etwas präziser sein?
Ja, das von OOo. Hinter /settings kommt noch /user
Es ist egal, wie du das umbenennst. Du kannst /user auch löschen.

Leder schreibst du vor /Data nur Pünktchen, so dass ich nur hoffen kann, dass das Benutzerverzechnis von OO3.3 ist,
und nicht von was anderem.
(Sorry, die Glaskugel funktioniert wieder nicht)

f

Re: OO3.3 portable stürzt beim Start ab

Beitrag von f » Sa, 12.05.2012 20:11

/Data/settings enthält eine .lock-Datei
-> Die .lock-Datei solltest du löschen.

Normalerweise wird sie automatisch gelöscht - wenn OOo beendet wird,
aber sie scheint bei dir hängen geblieben zu sein.

midas
*
Beiträge: 17
Registriert: Mo, 08.03.2010 15:01

Re: OO3.3 portable stürzt beim Start ab

Beitrag von midas » So, 13.05.2012 13:32

Es ist tatsächlich auf dem Desktop "installiert", weil es eine portable Installation ist (oder werden sollte).
Das Löschen der .lock-Datei ist wenig erfolgreich, da beim erneuten Starten von OO, dieses wieder abstürzt. Die .lock-Datei wird vorher neu erzeugt, aber beim Absturz nicht gelöscht. OO stürzt also auch ohne die .lock-Datei ab.

Der genaue Pfad zum user-Verzeichnis ist C:\Users\Midas\Desktop\TestportOO\Data\settings\user ; unter settings ist auch besagte .lock-Datei (nochmals, ich lösche die Datei immer bevor ich versuche zu OO starten).

'habe auch versucht das user-Verzeichnis zu löschen, wie erwartet wird dieses beim Programmstart neu erzeugt.
Funktioniert die Anleitung zum portabel machen vielleicht nur bei LibreOffice?

f

Re: OO3.3 portable stürzt beim Start ab

Beitrag von f » So, 13.05.2012 13:50

Das funktioniert auch bei OOo. So habe ich mir 3.2.1 mobil gemacht.

Portables mögen keine langen Pfade. Deinen Pfad finde ich nicht zwar besonders zu lang.
Aber versuche trotzdem das Ganze in ein Wurzelverzeichnis zu verschieben,
direkt nach zum Beispiel: D:\TestportOO

Wenn das keinen Erfolg bringt:
Bei mir sieht die Anpassung in bootstrap.ini so aus:

Code: Alles auswählen

UserInstallation=$ORIGIN/../../../Data/settings
Dein Eintrag ist auch nicht falsch, aber du kannst versuchen, ob es wie bei mir besser angenommen wird.

Benutzeravatar
balu
********
Beiträge: 3543
Registriert: Fr, 24.08.2007 00:28
Wohnort: Warstein

Re: OO3.3 portable stürzt beim Start ab

Beitrag von balu » So, 13.05.2012 14:56

Hallo ihr beiden Einzelkämpfer :wink:

die Anleitung die ich für LO erstellt (zusammengefasst) hatte, funktioniert auch für OOo ab 3.x.x. Habe ich schon mehrfach angewendet. Ja sogar für AOO 3.4.0 rc1, die Finale habe ich noch nicht getestet, funzt die Anleitung. Jedoch habe ich noch NIE! auf dem Desktop "installiert", wüsste auch gar nicht was das für einen Sinn hat. Im Gegenteil, ich glaub ehern das dies sogar die Probleme macht.

Frage: Warum auf den Desktop, welchen Sinn soll das ergeben?
Meine Empfehlung: NICHT aufm Desktop!


Meine Pfade auf der Festplatte für die Portables sehen in etwa so aus, je nach Version.

D:\PORTABLE\BUERO\OpenOffice\3.3.0
D:\PORTABLE\BUERO\OpenOffice\AOOo 3.4.0 rc1

Wenn ich also nach dem Pfad gefragt werde, gebe ich Beispielsweise D:\PORTABLE\BUERO\OpenOffice\{versionsnummer} an. Und das hat bis jetzt auch immer ohne Probleme funktioniert.

Und das ist meine bootstrap.ini für AOO

Code: Alles auswählen

[Bootstrap]
BaseInstallation=${OOO_BASE_DIR}
InstallMode=<installmode>
ProductKey=OpenOffice.org 3.4
UserInstallation=$ORIGIN/../Data/settings
[ErrorReport]
ErrorReportPort=80
ErrorReportServer=
Also midas, versuchs noch mal mit einem normalem Verzeichnis. Ich wünsch dir viel Erfolg daei :).



Gruß
balu
Sei öfter mal ein Faultier, sag öfter mal "Ach was!" Dann kriegst du keinen Herzinfarkt, und hast ne menge Spass.

wehr rächtschraipfähler findet khan si behalden :D

midas
*
Beiträge: 17
Registriert: Mo, 08.03.2010 15:01

Re: OO3.3 portable stürzt beim Start ab

Beitrag von midas » So, 13.05.2012 20:21

Hallo,

Danke, ein Verschieben vom Desktop hat's behoben. Es gab keinen besonderen Sinn warum es der Desktop sein sollte, es ist ist schlicht der Ort gewesen an dem das Installationspaket runtergeladen wurde.
THX nochmals.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste