Dienstplan erstellen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Jupp
***
Beiträge: 77
Registriert: Fr, 12.01.2007 14:09

Dienstplan erstellen

Beitrag von Jupp » Mo, 20.06.2011 19:08

Hallo NG,

ich habe einen etwas komplexeren Dienstplan erstellt, der Plus- und Minusstunden errechnet etc., wenn man in der Datumsliste die entsprechenden Arbeitsstunden einträgt.
Ich möchte nun, dass ich die Dienste nur mit F oder S bezeichne, und trotzdem die entsprechenden Stunden berechnet werden, also: F = 06:00 Stunden, S = 08:00 Stunden.
Steht in der Liste "F", so soll das Programm dann den entsprechenden Wert mit 06:00 berechnen. Ist das möglich?

Danke für Hilfe
Jupp

gripslund
***
Beiträge: 82
Registriert: So, 04.06.2006 09:46

Re: Dienstplan erstellen

Beitrag von gripslund » Mo, 20.06.2011 19:31

=wenn(a1="F";"06:00";wenn(a1="S";"08:00";""))

nur so als Tipp :)

gripslund

Waldschrat

Re: Dienstplan erstellen

Beitrag von Waldschrat » Mo, 20.06.2011 19:45

Hallo Jupp,

für einen Bereich:

Code: Alles auswählen

=ZÄHLENWENN(A1:K1;"F")*6+ZÄHLENWENN(A1:K1;"S")*8

Jupp
***
Beiträge: 77
Registriert: Fr, 12.01.2007 14:09

Re: Dienstplan erstellen

Beitrag von Jupp » Mo, 20.06.2011 20:15

Hmm, ich weiss nicht wieso, aber bei mir klappt das nicht.

Bei mir sieht es so aus:

B3 bis B33 ist die Dienstspalte. Dort will ich "F" für Frühdienst eintragen oder "S" für Spätdienst.
In der Zelle AA4 findet die Rechnung statt: =SUMME(B3:B33)
Format in allen Zellen ist [HH]:MM

Soo, ich will nun in B3 bis B33 "F" schreiben, aber in AA4 soll dann mit 06:00 gerechnet werden....oder ich schreibe "S" und es wird mit 08:00 gerechnet.

Mit keiner eurer beiden Formeln bekomme ich das hin ... Bin ich zu doof? Wer kann mir das Schritt für Schritt erklären?
Gruß Jupp

Benutzeravatar
balu
********
Beiträge: 3650
Registriert: Fr, 24.08.2007 00:28
Wohnort: Warstein

Re: Dienstplan erstellen

Beitrag von balu » Mo, 20.06.2011 23:06

Hallo Jupp,

nein Du bist nicht zu doof. Du bist nur noch nicht Wissend genug :wink:.

Also, mit =SUMME() können nur Zahlen/Werte addiert werden. Text jedoch geht damit überhaupt nicht. Und "F" oder "S" ist nun mal halt Text. Leicht modifiziert kannst Du die Formel von Waldschrat in AA4 nehmen.

Code: Alles auswählen

=(ZÄHLENWENN(B3:B33;"F")*6+ZÄHLENWENN(B3:B33;"S")*8)/24
Kommst Du damit zurecht?


Gruß
balu
Sei öfter mal ein Faultier, sag öfter mal "Ach was!" Dann kriegst du keinen Herzinfarkt, und hast ne menge Spass.

wehr rächtschraipfähler findet khan si behalden :D

Weissmar

Re: Dienstplan erstellen

Beitrag von Weissmar » Fr, 17.08.2018 11:40

Hier kannst du alles mit einem Programm erledigen https://planovo.de/dienstplan-erstellen

Moderationshinweis:
Bitte keine "alten" Threads mehr aufwärmen.
Siehe auch Infos zur Forenbenutzung (dort unter: "Eröffnet neue Threads").
Eröffne bitte einen neuen Thread mit Deiner Frage.
Thread geschlossen.

Gesperrt