führende Nullen entfernen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Marco Schaening

führende Nullen entfernen

Beitrag von Marco Schaening » Fr, 09.09.2011 12:53

Hallo Ihr da,

ich habe in einer Spalte Modellnummern ( Daten kommen aus einer OCR Software )
003
033
333
Nun sollen die führenden Nullen entfernt werden
3
33
333

Da ich kein Formelexperte bin habe im Forum und google nach einer fertigen Formel gesucht und diese gefunden.
=WENN(ISTFEHLER(FINDEN("49";A1));A1;"0"&TEIL(A1;FINDEN("49";A1)+2;99))
Quelle:http://www.herber.de/forum/archiv/236to240/t237931.htm

Für 003 habe ich diese Formel so umgewandelt =WENN(ISTFEHLER(FINDEN("00";I13));I13;""&TEIL(I13;FINDEN("00";I13)+2;99))
Für 033 ist dann: =WENN(ISTFEHLER(FINDEN("0";I11));I11;""&TEIL(I11;FINDEN("0";I11)+1;99))

Wie kann ich beide gleichzeitig anwenden? Wie verbinden?

LG
Marco

hiob
****
Beiträge: 155
Registriert: Di, 05.07.2011 23:47

Re: führende Nullen entfernen

Beitrag von hiob » Fr, 09.09.2011 12:59

hi Marco, versuch mal =WECHSELN(A1;0;"")*1 wenn deine 033,003 oder 333 text sind wovon ich ausgehe sollte das funzen... in A stehen die werte (003 usw.)
gruß hiob

lern- und wissbegieriger oO-anfänger
mit körperlichem handicap...

hiob
****
Beiträge: 155
Registriert: Di, 05.07.2011 23:47

Re: führende Nullen entfernen

Beitrag von hiob » Fr, 09.09.2011 13:11

hi Marco, kommando zurück, damit würdest du alle nullen entfernen. wenn es nur vorn welche gibt ist's okay, aber sonst kannst du

Code: Alles auswählen

=WENN(A1="";"";TEIL(A1;VERGLEICH(1;TEIL(A1;SPALTE($A$1:$X$1);1)<>"0";0);99)*1)

verwenden als matrixformel abschließen... wenn es sich um texte im zahlenformat handelt und du sie als zahlen braucht, wenn auch sowas hier vorkommen kann 03da0450 ginge

Code: Alles auswählen

=WENN(A1="";"";TEIL(A1;VERGLEICH(1;TEIL(A4;SPALTE($A$1:$X$1);1)<>"0";0);99))
auch als matrixformel abschließen...
gruß hiob

lern- und wissbegieriger oO-anfänger
mit körperlichem handicap...

hiob
****
Beiträge: 155
Registriert: Di, 05.07.2011 23:47

Re: führende Nullen entfernen

Beitrag von hiob » Fr, 09.09.2011 13:28

oder eine längere für "alle" fälle..:

Code: Alles auswählen

WENN(A1="";"";WENN(ISTFEHLER(TEIL(A1;VERGLEICH(1;TEIL(A1;SPALTE(A$1:X$1);1)<>"0";0);99)*1);TEIL(A1;VERGLEICH(1;TEIL(A1;SPALTE(A$1:X$1);1)<>"0";0);99);TEIL(A1;VERGLEICH(1;TEIL(A1;SPALTE(A$1:X$1);1)<>"0";0);99)*1))
passt, wackelt und hat luft (nach oben für kürzungen...)
gruß hiob

lern- und wissbegieriger oO-anfänger
mit körperlichem handicap...

Marco Schaening

Re: führende Nullen entfernen

Beitrag von Marco Schaening » Fr, 09.09.2011 13:43

Hallo Hiob,

ich bin verängstig. Ich habe schon mit normalen Formel probleme, aber jetzt .... HILFE !

Ok, Spaß darf sein. Irgend etwas geht nicht und habe immer nur Err:501,522.
In A1 stehen die Daten z.B. 003,003a,...
In B1 habe ich die Matrix copiert und strg+shift+enter oder per [x]Matrixoption abgeschlossen.

Lg Marco

hiob
****
Beiträge: 155
Registriert: Di, 05.07.2011 23:47

Re: führende Nullen entfernen

Beitrag von hiob » Fr, 09.09.2011 13:53

hi Marco, bei mir funktioniert's und es ist ja nur ein vorschlag; vielleicht kommt ja noch was nach..!?!?

Bild

vielleicht kannst du (d)eine (beispiel)datei hochladen..?
gruß hiob

lern- und wissbegieriger oO-anfänger
mit körperlichem handicap...

Marco Schaening

Re: führende Nullen entfernen

Beitrag von Marco Schaening » Fr, 09.09.2011 14:22

Hallo Hiob,

deine Matrix ist der Hammer. Es läuft sehr gut. Jetzt ist mein Kopf wieder Wach und die Errors haben sich aus den Staub gemacht.

Damit ist das Problem behoben.

DANKE und LG Marco

SKW

Re: führende Nullen entfernen

Beitrag von SKW » Fr, 11.05.2018 09:10

Hallo zusammen,

Formel funktionieren super, aber wie bekomme ich die komplette Spalte mit der Formel gefüllt?
Wie bei anderen Formeln das Feld einfach per Maus auf die komplette Spalte ziehen, klappt ja leider nicht..

LG SKW

Gast

Re: führende Nullen entfernen

Beitrag von Gast » Fr, 11.05.2018 09:19

Servus.

die Spalte markieren und dann mit Daten - Text in Spalten - alles abwählen und OK.
Aus dem Text wird dann eine Zahl.

Gast

Gast

Re: führende Nullen entfernen

Beitrag von Gast » Fr, 11.05.2018 09:24

Servus,

mit der gedrückten STRG Taste und Maus am Kreuz runterziehen.
Wenn Links oder Rechts der Spalte Werte stehen, dann Doppelklick am Kreuz.

Gast

echo
******
Beiträge: 754
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: führende Nullen entfernen

Beitrag von echo » Fr, 11.05.2018 16:16

Hallo
Habe gerade die Formellösungen gesehen und bin ein wenig erstaunt.
Hast du mal versucht die Nummern in eine Berechnung einzubauen?
Normalerweise sollte es so sein, das Calc bei einer Berechnung erkennt, das es sich um eine Zahl handelt und diese dementsprechend umwandelt.
Also einfach =A1*1. Wenn das funktioniert, sollten auch alle führenden Nullen Geschichte sein.

Gibt zB. es Sonder- oder Leerzeichen in dem Strang müssen diese zuerst weg,erst danach multiplizieren:
Beispiel Strang mit Ziffern,und möglicherweise Leerzeichen und Bindestrich:
=wechseln(wechseln(A1;" ";"");"-";"")*1
Gruß Holger

Gesperrt