Seite 1 von 2

Zeitliche Abstände ermitteln und anzeigen

Verfasst: Sa, 07.10.2017 21:18
von little fingers
Hallo

Ich würde gerne den zeitlichen Abstand des Einsatzes einer Person zum nächsten Einsatz in einer separaten Tabelle ermitteln und anzeigen.

Im Moment stehe ich da echt auf dem Schlauch und würde mich freuen, wenn Ihr mir dabei helfen könntet.

Ich habe eine Bsp-Tabelle angehängt!

Vielen lieben Dank

mfg
Ingo
Zeitabstaende1.ods
(43.04 KiB) 13-mal heruntergeladen

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: So, 08.10.2017 07:34
von HeritzP
Hallo,

wo soll was stehen?


Gruß HeritzP

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: So, 08.10.2017 11:27
von little fingers
Hallo HeritzP
Ich habe die Datei ergänzt und neu hochgeladen.
Ich hoffe, dass ich es geschafft habe, es verständlich zu machen, was ich eigentlich erreichen möchte.


A7 in Verbindung mit A6 S10 in Verbindung mit Q9

Fahrer AA fängt am Sonntag um 16:00 Uhr an, hat am Donnerstag davor 22:30 Uhr Feierabend
Hierbei beträgt die Zeitdifferenz gemessen in Stunden 65,50

I13 in Verbindung mit I12 A7 in Verbindung mit A6

Fahrer AA fängt am Dienstag um 16:30 Uhr an, hat am Sonntag davor 22:30 Uhr Feierabend
Hierbei beträgt die Zeitdifferenz gemessen in Stunden 43,00

Q10 in Verbindung mit Q9 I13 in Verbindung mit I12

Fahrer AA fängt am Donnerstag um 17:00 Uhr an, hat am Mittwoch davor 01:30 Uhr Feierabend
Hierbei beträgt die Zeitdifferenz gemessen in Stunden 39,50


MfG
Ingo

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: Mi, 11.10.2017 19:30
von little fingers
Hallo
Hat denn niemand ansatzweise eine Idee, wie ich das realisieren könnte?

Ich habe inzwischen einiges durchprobiert und bin eigentlich noch da, wo ich die Frage gestellt habe.

komme echt nicht weiter.

mfg
Ingo

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: Mi, 11.10.2017 19:54
von HeritzP
Hallo,

das Problem ist, um diese Stunden berechnen zu können, eine Zeit über mehre Tage benötigt wird.
Nur eine Uhrzeit ohne Datum ist nicht ausreichend.
Das ist hier so nicht gegeben.

Gruß HeritzP

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: Mi, 11.10.2017 20:56
von Gast
und wenn mann fiktives Datum in die Tabelle einbaut?
Quasi ein Hilfsdatum?
MfG

Ingo

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: Do, 12.10.2017 07:21
von Stephan
Hat denn niemand ansatzweise eine Idee, wie ich das realisieren könnte?
normalerweise ist bei Calc jeder Zeitpunkt ein ganz konkreter, d.h. es gibt keine 'allgemeinen' Zeiten sondern jede Zeit entspricht eine Uhrzeit an einem bestimmten Datum.

Da es nur darum geht Differenzen zu ermitteln egal sein dürfte welches Datum, würde ich irgendeine konkrete Woche zugrundelegen, denn dann wären die Differenzen leicht zu ermitteln.
DAzu reicht es auch die Formeln zu ergänzen, wie folgt:

Zelle I13:
=WENN(ISTNV(VERGLEICH(LZeit.$B$1:$B$1048576;VERGLEICH(I11;LZeit.$A$1:$A$1048576;0)));"";INDEX(LZeit.$B$1:$B$1048576;VERGLEICH(I11;LZeit.$A$1:$A$1048576;0)))+2

Zelle Q10:
=WENN(ISTNV(VERGLEICH(LZeit.$B$1:$B$1048576;VERGLEICH(Q8;LZeit.$A$1:$A$1048576;0)));"";INDEX(LZeit.$B$1:$B$1048576;VERGLEICH(Q8;LZeit.$A$1:$A$1048576;0)))+4

Die Zellanzeigen bleiben gleich, aber da die Werte nun die realen Zeitabstände ausdrücken kann man Differenzen einfach ausrechnen.



Gruß
Stephan

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: Do, 12.10.2017 10:30
von little fingers
Hallo Stephan!

Danke schon einmal für die Info!

Frage hier zu nochmal:

was muss ich denn z. B. in der Zeile (E44), in Abhängigkeit zu der flexiblen Zeile (B44) wo ich die Differenz darstellen möchte,
als formel eintragen?

MfG Ingo

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: Do, 12.10.2017 19:28
von Stephan
Frage hier zu nochmal:
ich hatte wie gewünscht eine "ansatzweise Idee" geliefert, eine vollständige Lösung habe ich auch nicht.
was muss ich denn z. B. in der Zeile (E44), in Abhängigkeit zu der flexiblen Zeile (B44) wo ich die Differenz darstellen möchte,
als formel eintragen?
nach meinem Vorschlag müsste dann man dann wohl eine Hilfstabelle erstellen die links bis Donnerstag erweitert ist und in der die Einträge anders angeordnet sind, nämlich bei jedem Tag: linke Spalte Fahrername und daneben Anfasngs- und Endzeit, dann könnte man mittels SVERWEIS()-Formel die Zeiten ermitteln die zum Fahrernamen passen und Zeit-Differenzen bilden.


Gruß
Stephan

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: So, 15.10.2017 12:06
von little fingers
Danke, werde ich ausprobieren!

MfG

Ingo

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: Mo, 16.10.2017 04:33
von little fingers
Hallo..
Ich habe verschieden Dinge probiert und experementiert und bin leider zu keinem befriedigenden Ergebnis gekommen!
Ich habe eine ander Tabelle angelegt, in der Hoffnung, dass ich hier für mich die Lösung finde.

Nur leider ohne Ergebnis!
Könnte man mir da vielleicht noch einmal helfen?

Wäre echt Super!

MfG

Ingo
Zeitabstaende3.ods
(67.98 KiB) 11-mal heruntergeladen

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: Mo, 16.10.2017 14:19
von Mondblatt24
Hallo,
das sollte meiner Meinung nach dein Ansatz sein.

Gruß Peter

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: Mo, 16.10.2017 14:49
von little fingers
Hallo Mondblatt!
Vielen Dank erstmal, für Deine Mühe und Zeit!

=((D4+E4)-(A4+B4))*24
Deine Lösung würde voraussetzen, dass die Spalten IMMER, unabhängig vom Datum, fest stehen.

Es kann aber sein, dass Spalten, dann leer bleiben.!

Für die bessere Übersicht habe ich die Wochentage fest in Spalten eingebaut und es kann, je nach Einsatz der MA, da zu Verschiebungen kommen.
Sprich, feste Koordiaten, würden mit meiner Tabelle nicht funzen!
Oder übersehe ich da jetzt was?

MfG Ingo

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: Di, 17.10.2017 10:36
von Mondblatt24
Hallo l.f.,
es ist nicht die Lösung, sondern nur eine Möglichkeit wie es funktionieren könnte.

Gruß Peter

Re: Zeitliche Abstände ermitteln und anzeigen

Verfasst: Di, 17.10.2017 11:51
von Mondblatt24
Hallo l.f.,
wenn z.B.: Anfang Sonntag um 01:30, ist damit Montagmorgen gemeint?
Genauso Dienstag 23:30, Montagabend oder Dienstagabend?

Gruß Peter