Seite 1 von 1

Bedingte Formatierung mit leerer Zelle

Verfasst: So, 04.02.2018 10:26
von Dart
Hallo zusammen,

ich lese jetzt seit einer geschlagenen Stunde in dem Forum über die bedingte Formatierung.
Mein Problem ist eine Bestandsliste mit 3 Möglichkeiten und der dazu gehörigen farblichen Markierung.

Meine Bestandsliste umfasst folgende Möglichkeiten:

1] Wert ist gleich 3 oder größer -> Feld soll grün sein
2] Wert ist 0, 1 oder 2 -> Feld soll rot werden
3] Feld hat keinen Inhalt, also leer -> Feld soll weiß sein

Ich nutze daher folgende Bedingungen:

1] Zellenwert ist zwischen 0 und 2 -> Vorlage Rot (Einfärbung)
2] Zellenwert ist größer oder gleich 3 -> Vorlage Grün (Einfärbung)

Aber was ich nun als Bedingung 3 nehme habe ich noch nicht herausgefunden.

Nutze ich die vorgeschlagenen Lösungen von Balu, Karo oder Stephan geht es schief.

Dazu gehören:
ISTLEER
=WENN(A1<>0)
=WENN(A1=0)
=WENN(A1="")
=WENN(A1<>"")
(A1=0)*(A1<>"")

Ich vermute ich mach hier irgendwo einen Denkfehler, oder setze die Formel nicht korrekt ein.

Re: Bedingte Formatierung mit leerer Zelle

Verfasst: So, 04.02.2018 10:43
von Stephan
Calc unterscheidet, an dieser Stelle, scheinbar nicht sauber zwischen Null und Leer. Folgendes geht bei mir:
bedingungen.gif
bedingungen.gif (31.09 KiB) 1273 mal betrachtet
1] Wert ist gleich 3 oder größer -> Feld soll grün sein
2] Wert ist 0, 1 oder 2 -> Feld soll rot werden
3] Feld hat keinen Inhalt, also leer -> Feld soll weiß sein
Zellen sind keine Felder ... wirklich nicht.


Gruß
Stephan

Re: Bedingte Formatierung mit leerer Zelle

Verfasst: So, 04.02.2018 11:25
von HeritzP
Hallo,

oder so.
Formatierung.png
Formatierung.png (26.03 KiB) 1257 mal betrachtet
Gruß HeritzP