Wenn-Dann-Fkt

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

0101

Wenn-Dann-Fkt

Beitrag von 0101 » Do, 05.04.2018 13:41

Hallo,

ich habe folgendes Problem:
Spalte B hat Orte und Spalte C Landkreise. In einigen Fällen steht "kreisfreie Stadt" als Landkreis.
Ich möchte nun in Spalte C den Landkreis gefiltert haben. Das heißt: "kreisfreie Stadt" soll nie drin stehen. Ich benötige also eine Formel die checkt, ob in Spalte C "kreisfreie Stadt" steht und wenn ja, dann der Text aus Spalte B genommen wird. Erscheint "kreisfreie Stadt" nicht in Spalte C, dann soll der Text aus C genommen werden.
Oder kurz: Wenn "kreisfreie Stadt" in C, dann nimm Text aus B. Wenn nicht "kreisfreie Stadt" in C, dann nimm weiterhin den Text in C.

Bisher habe ich: =WENN(ISTFEHLER(FINDEN("kreisfreie Stadt";C4));"";B14)
Problem: "Kreisfreie Stadt" wird mit Ort ersetzt. Aber da, wo der Landkreis einen anderweitigen Namen hat, steht nichts drin.

Danke für die Hilfe :)

Mondblatt24
*****
Beiträge: 205
Registriert: So, 14.05.2017 16:11

Re: Wenn-Dann-Fkt

Beitrag von Mondblatt24 » Do, 05.04.2018 13:58

Hallo,
du kannst nicht in Spalte C suchen und gleichzeitig in Spalte C was ersetzen.

Gruß Peter
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, können im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

Antworten