Antwort: MAX, MIN, ODER mit Arrays

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Lupo1
****
Beiträge: 144
Registriert: Sa, 13.10.2012 10:36

Antwort: MAX, MIN, ODER mit Arrays

Beitrag von Lupo1 » Di, 22.05.2018 08:22

viewtopic.php?f=2&t=28666&start=15#p274629

stellte hierzu am 13.4.18 eine Frage. Sinngemäß: Wenn in A1 bis B3 die Werte

1 2
3 1
2 4

stehen, sei MAX nicht in der Lage, die Zeilenmaxima zu addieren.

=SUMME(MAX(A1:B3)) geht nicht. Begründung: Die im Betreff genannten Funktionen (und weitere, wie z.B. MEDIAN) können Arrays nur innen verarbeiten, aber nicht nach außen durchreichen. Eine Ursache dafür dafür mag sein, dass es dafür eines Durchschleifungskennzeichens (=als weiteres Argument) bedürfte, welches man jedoch vor knapp 40 Jahren bei Lotus 1-2-3 nicht vorsah. Am Beispiel ist außerdem erkennbar, dass man nicht wüsste, was genau gemeint wäre: Zeilen- oder Spalten- oder sonstige Maxima.

{=SUMME(WENN(A1:A3>B1:B3;A1:A3;B1:B3))} mit Nr. 5 ist daher nötig, um die gewünschten 2 + 3 + 4 zu 9 zu addieren.

Das gleiche gilt für ODER (vor 9 Jahren durch Karolus in dem gleichen Thread mit den dortigen Arrays durch + ersetzt).
MfG Lupo - LO5462+LO6062 Win10Pro