Bedingung Zelle enthält Text

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

Tabellenfeind
Beiträge: 5
Registriert: Mo, 16.07.2018 18:35

Bedingung Zelle enthält Text

Beitrag von Tabellenfeind » Mo, 16.07.2018 18:47

Hallo,
Ich würde gerne die ZÄHLENWENN Funktion benutzen, um in einem bestimmten Bereich alle Zellen zu zählen, die irgendeinen Text enthalten, egal welchen. Ich komme aber auch nach längerer Recherche nicht darauf, was ich als Bedingung einsetzen muss.
Vielen Dank schonmal im Vorraus!

echo
******
Beiträge: 751
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Bedingung Zelle enthält Text

Beitrag von echo » Mo, 16.07.2018 19:18

Hallo, ein Beispiel für A1:A100
=ANZAHL2(A1:A100)-ANZAHL(A1:A10)
(Anzahl2=Alle minus Anzahl=Werte)
oder
=SUMMENPRODUKT(ISTTEXT(A1:A100)*1)

Tabellenfeind
Beiträge: 5
Registriert: Mo, 16.07.2018 18:35

Re: Bedingung Zelle enthält Text

Beitrag von Tabellenfeind » Mo, 16.07.2018 19:34

Vielen Dank, so funktioniert es.
Aber warum genau kann ich das nicht über die ZÄHLENWENN Funktion machen? Gibt es keine Möglichkeit als Bedingung einzugeben dass die Zelle Text enthält?

echo
******
Beiträge: 751
Registriert: Fr, 14.11.2008 15:27
Wohnort: BRA - Nds

Re: Bedingung Zelle enthält Text

Beitrag von echo » Mo, 16.07.2018 19:39

Hallo, habe ein wenig probiert, weil ich normaler weise ehr SUMMENPRODUKT verwende, also:
=ZÄHLENWENN(A1:A100;">*")
sollte auch funktionieren, liefert alle nicht leeren Zellen mit Text

=ZÄHLENWENN(A1:A100;"<>*")
liefert alle nicht leeren Zellen egal ob Zahl oder Text

=ZÄHLENWENN(A1:A100;">0")
liefert alle nicht leeren Zellen mit Werten <>0 (abweichend von Anzahl() dort wird 0 auch mit gezählt.)

Gruß Holger

Tabellenfeind
Beiträge: 5
Registriert: Mo, 16.07.2018 18:35

Re: Bedingung Zelle enthält Text

Beitrag von Tabellenfeind » Mo, 16.07.2018 20:02

Super vielen Dank für die Mühe!
Hatte mich schon gewundert ob meine Idee komplett daneben war

Mondblatt24
*****
Beiträge: 247
Registriert: So, 14.05.2017 16:11

Re: Bedingung Zelle enthält Text

Beitrag von Mondblatt24 » Mo, 16.07.2018 20:08

Hallo,
funktioniert auch ohne "*".

VG Peter
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

quotsi
*****
Beiträge: 235
Registriert: Do, 14.11.2013 10:04

Re: Bedingung Zelle enthält Text

Beitrag von quotsi » Mi, 18.07.2018 14:06

echo hat geschrieben:
Mo, 16.07.2018 19:39
Hallo, habe ein wenig probiert,...
=ZÄHLENWENN(A1:A100;">0")
liefert alle nicht leeren Zellen mit Werten <>0 (abweichend von Anzahl() dort wird 0 auch mit gezählt.
Das glaube ich nicht. Negative Zahlen, also <0, dürften nicht mitgezählt werden :lol:
win7prof - Avira - LO 5.4.7.2 (x64) - AOO 4.1.5

Antworten