Zählenwenn mit Rechenzeichen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

delta9
***
Beiträge: 95
Registriert: Fr, 19.03.2010 15:28

Zählenwenn mit Rechenzeichen

Beitrag von delta9 » Fr, 31.08.2018 14:19

Mit Zählenwenn kann man das Auftreten von Inhalten zählen
Enthält die Spalte A die Einträge

Code: Alles auswählen

Apfel
Birne
Apfel
So liefert zählenwenn (A1:A10:"Apfel") die gewünschte 2.
Aber wenn ich nun in die Zellen schreibe

Code: Alles auswählen

Apfel(rot)
Birne(rot)
Apfel(rot)
So liefert zählenwenn (A1:A10:"Apfel(rot)") eine Null! Die Klammer scheint zu stören, genauso wie Rechenzeichen wie +.

Gibt es eine andere Lösung, außer die komplizierte Lösung, gefährliche Zeichen in einer Behelfszelle zu erssetzen?

Ich verwende Open Office 3.4.1
Danke für Tipps.

hylli
*******
Beiträge: 1650
Registriert: Mi, 22.02.2006 19:37

Re: Zählenwenn mit Rechenzeichen

Beitrag von hylli » Fr, 31.08.2018 14:41

Kann es sein, dass da einfach ein Leerzeichen in Deiner Formel fehlt?

Bei mir funktioniert es unter LibreOffice 5.4.5.1 problemlos.

Eine Alternative Variante wäre zum Beispiel, Frucht und Farbe auf 2 Spalten aufzuteilen, und die Anzahl per Summenprodukt zu ermitteln.

Edit:
Geht auch über eine Spalte mit Summenprodukt, wenn ZÄHLENWENN in OpenOffe 3.4.1 partout nicht will.

Hylli
Dateianhänge
Zaehlenwenn_Aepfel_und_Birnen.ods
(12.64 KiB) 24-mal heruntergeladen
Ein Dankeschön für eine Lösung tut nicht weh!
Wer eine Lösung selbst findet, sollte die für die Nachwelt auch posten!

Geschäftlich: LibreOffice 5.1.x ("Still") unter Windows 7 32/64bit
Privat: LibreOffice 5.x unter Linux Mint 18.x Cinnamon 64bit u. Arch Anywhere "Mate"

Gast

Re: Zählenwenn mit Rechenzeichen

Beitrag von Gast » Fr, 31.08.2018 15:00

Servus,

in den Einstellungen ist reguläre Ausdrücke ermöglichen aktiviert.

Gast

Stephan
********
Beiträge: 10595
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Zählenwenn mit Rechenzeichen

Beitrag von Stephan » Fr, 31.08.2018 15:40

Gibt es eine andere Lösung, außer die komplizierte Lösung, gefährliche Zeichen in einer Behelfszelle zu erssetzen?

Deine Formel ist falsch und muss richtig lauten:

=ZÄHLENWENN(A1:A10;"Apfel(rot)")

außerdem darf Reguläre Ausdrücke ..." unter Optionen NICHT aktiviert sein.


Gruß
Stephan

delta9
***
Beiträge: 95
Registriert: Fr, 19.03.2010 15:28

Re: Zählenwenn mit Rechenzeichen

Beitrag von delta9 » Fr, 31.08.2018 16:26

Vielen Dank an alle!
Die Lösung war es, die regulären Ausdrücke abzuschalten!
Stefan

mikeleb
******
Beiträge: 723
Registriert: Fr, 09.12.2011 16:50

Re: Zählenwenn mit Rechenzeichen

Beitrag von mikeleb » Fr, 31.08.2018 21:14

Hallo,
alternativ kannst du auch die Klammern maskieren:

Code: Alles auswählen

=ZÄHLENWENN(A1:A10;"Apfel \(rot\)")
dann klappt es auch mit aktivierten regulären Ausdrücken.
Gruß,
mikeleb

Antworten