Mac - 4.1.3 - Beschriftungen fehlen

Setup und Komponenten-übergreifende Probleme.

Moderator: Moderatoren

jm@erdnah.de
Beiträge: 5
Registriert: Mi, 04.01.2017 09:36

Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von jm@erdnah.de » Mi, 04.01.2017 09:46

Hallo zusammen,
ich bin neu hier und habe natürlich ein Problem mit OpenOffice...

Ich nutze OpenOffice schon länger aber bei meinem letzen System-Update auf OS X 10.11.3 sind alle Beschriftungen in OpenOffice verschwunden und trotz diverser Rumprobiererei und Neuinstallation nicht wieder aufgetaucht. Um das zu zeigen, habe ich einen Screenshot angehängt.

Fällt jemandem etwas Zielführendes dazu ein? Ich bin natürlich beim checken eingeschränkt weil ich nichts lesen kann ;)

Es wäre super, wenn mir jemand einen Tipp dazu geben könnte.

Gruß, jörg
Bildschirmfoto 2017-01-04 um 09.44.07.png
Bildschirmfoto 2017-01-04 um 09.44.07.png (111.01 KiB) 628 mal betrachtet

Stephan
********
Beiträge: 9671
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von Stephan » Mi, 04.01.2017 09:55

Fällt jemandem etwas Zielführendes dazu ein?
Ja. Mit hoher Wahrscheinlichkeit ist Dein OO-Benutzerverzeichnis nicht in Ordnung. Benenne DEin Benutzerverzeichnis um, dann legt OO beim nächsten Programmstart ein Neues an und die Beschriftungen dürften wieder da sein:
viewtopic.php?f=27&t=54231#p206070

Gruß
Stephan

jm@erdnah.de
Beiträge: 5
Registriert: Mi, 04.01.2017 09:36

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von jm@erdnah.de » Mi, 04.01.2017 14:19

Hallo Stephan,
vielen Dank für den Tipp. Das hatte ich schon probiert.

Beim Mac liegt das Verzeichnis unter /Users/joerg/Library/Application Support/OpenOffice

Ich habe das Verzeichnis umbenannt, bekomme von OpenOffice brav ein neues angelegt ... aber der Effekt der fehlenden Beschriftungen bleibt. Auch nach einer erneuten Installation fehlen die Textinhalte der Oberfläche:
Bildschirmfoto 2017-01-04 um 14.14.26.png
Bildschirmfoto 2017-01-04 um 14.14.26.png (91.96 KiB) 599 mal betrachtet
Hm. Was meinst Du dazu?

Gruß, jörg

Stephan
********
Beiträge: 9671
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von Stephan » Mi, 04.01.2017 15:05

Hm. Was meinst Du dazu?
Garnichts, weil ich leider nichts dazu weiß. Genauer gesagt ich kenne mich mich MacOS nicht im Geringsten aus und es scheint wohl ein Mac-spezifisches Problem zu sein, unter Windows würde ich jetzt jedenfalls sagen: 'kann garnicht sein'.

Da, nach Deiner Beschreibung, auch nicht der Versionswechsel von OO schuld war sondern ein Betriebssystem-Update kann auch kaum der Hinweis helfen die ursprüngliche OO-Version wieder zu installieren und da Dein zweiter Screenshot den Registrierungsdialog zeigt bin ich ebenso diesbezüglich sich das das Umbenennen des Benutzerverzeichnisses erfolgreich war.

Die einzige Mutmaßung die ich hätte, aber ich bin eigentlich überzeugt das das nichts damit zu tun hat, wäre Java zu kontrollieren und ein 6er Java/JRE zu installieren, denn es gibt bei OO 4.1.2/4.1.3 bekannte Probleme mit Java:
https://cwiki.apache.org/confluence/pag ... teProbleme


Gruß
Stephan

Gast

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von Gast » Do, 05.01.2017 09:12

Hallo Stephan,
vielen Dank für die Einschätzung und den Tipp zur Java-Version. Es ist natürlich so ein Ding, Java zu downgraden um OpenOffice an den Start zu bringen...
Ich habe die aktuellste Version von Java eingesetzt und damit besteht das Problem weiterhin. Ist es stattdessen vielleicht ein Weg, die 3er Version von OpenOffice zu verwenden?

Gruß, Jörg

Stephan
********
Beiträge: 9671
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von Stephan » Do, 05.01.2017 10:21

Es ist natürlich so ein Ding, Java zu downgraden um OpenOffice an den Start zu bringen...
Lassen sich denn bei MacOS nicht mehrere Java-Versionen parallel installieren? Zumindest unter MS Windows ist das möglich und für OO faktisch Standard, da ja OO ein 32 Bit Java benötigt und Windows heute hauptsächlich in 64 genutzt wird. Ich habe bei mir unter Windows7 z.B. drei Java-Versionen parallel installiert.
Ich habe die aktuellste Version von Java eingesetzt und damit besteht das Problem weiterhin.
Weiterhin? Das Problem besteht u.a. GERADE mit der neuesten Version, das steht doch in den verlinkten Release-Notes.
Nochmal betone ich das ich ohnehin nicht glaube das Dein konkretes Problem durch Java verursacht ist, einzig könnte man das Restrisiko zumindest testweise ausschließen indem man ein Java nutzt wie in den Release-Notes beschrieben, also ein 6er
Ist es stattdessen vielleicht ein Weg, die 3er Version von OpenOffice zu verwenden?
Warum probierst Du es nicht aus? Ich habe keinerlei Ahnung von MacOS und kenne auch den konkreten Fehler nicht, also kann ich Dir eine solche Frage leider nicht verlässlich beantworten.


Gruß
Stephan

Gast Peter

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von Gast Peter » Do, 05.01.2017 10:31

Hier hatte jemand ähnliche Probleme:
viewtopic.php?f=12&t=65193 (Mac OS X Yosemite Grafikprobleme in Menüs)
Vielleicht hilft es auch dir.
MfG

jm@erdnah.de
Beiträge: 5
Registriert: Mi, 04.01.2017 09:36

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von jm@erdnah.de » Do, 05.01.2017 11:50

Hallo Stephan, Hallo Peter,
danke für die Hilfe.

Ich habe nun zum einen probiert, die alte Javaversion zusätzlich zu installieren. Das hat auch brav funktioniert und ich habe nun die aktuelle und gleichzeitig die neue am Laufen. Allerdings fehlen die Beschriftungen noch immer.

Daraufhin habe ich Peters Tipp ausprobiert und habe damit die Systemschrift auf Lucida Grande und dann noch zu San Francisco umgestellt und sichergestellt, dass diese Fonts auch brav installiert sind... aber leider gibt es noch immer keine Beschriftungen...

Gruß, jörg

Stephan
********
Beiträge: 9671
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von Stephan » Do, 05.01.2017 12:22

Ich habe nun zum einen probiert, die alte Javaversion zusätzlich zu installieren. Das hat auch brav funktioniert und ich habe nun die aktuelle und gleichzeitig die neue am Laufen. Allerdings fehlen die Beschriftungen noch immer.
Nochmals mache ich darauf aufmerksam das ich nicht der Meinung bin das es an Java liegt.

Ein Problem besteht hingegen jetzt mit Gewissheit (und daran hatte ich nicht gedacht), wenn Du jetzt Java nachinstalliert hast, musst Du die nachinstallierte Version in OO unter Optionen aktivieren, was in Deinem Falle wohl nicht geht weil Du im Optionen-Dialog nicht genügend genau die Beschriftungen siehst.
Versuchen must Du es trotzdem, denn das nachinstallierte Java funktioniert garantiert ohne Aktivierung nicht. Fall Du also unter Optionen-OpenOffice-Java soviel erkennen könntest um Java zu aktivieren wäre dass prima, sonst hilft nur der im Konkreten extrem umständliche Weg:

-deinstalliere OO
-deinstalliere ALLE Java-Versionen
-installiere nur die 6er Java-Version
-installiere OO

OO sollte nun die 6er Version automatisch erkennen, weil es die Einzige ist, ich bin aber nur zu 90% sicher das das klappt.

-installiere abschliessend die eine neuere Java-Version

und zum vierten Male der Hinweis:
ich bin nicht sicher ob es an Java liegt glaube aber das es nicht an Java liegt, weshalb der gesamte aufgezeigte komplizierte WEg des de- und Neuinstallierens, praktisch wohl Garnichts bringen wird, allein weiß ich nicht wie man sonst Java in OO aktivieren könnte wenn man im entsprechenden Dialog Garnichts sieht, weil keine Beschriftungen da sind.


Gruß
Stephan

jm@erdnah.de
Beiträge: 5
Registriert: Mi, 04.01.2017 09:36

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von jm@erdnah.de » Do, 05.01.2017 14:20

Hallo Stephan, Hallo Peter,

erstmal vielen Dank für den Support. Ich glaube, das bekommen wir nicht gelöst. Ich habe noch mal versucht im unbeschrifteten Einstellungs-Menue Java zu aktivieren aber irgendwann muss man sich wahrscheinlich einfach eingestehen, dass das nicht funktioniert.

Ich bleibe dran und hoffe, dass es irgendwann mal eine OpenOffice Version geben wird, die ich auf meiner Kiste einfach wieder installieren und nutzen kann.

Gruß, jörg

Stephan
********
Beiträge: 9671
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von Stephan » Do, 05.01.2017 14:36

Ich habe noch mal versucht im unbeschrifteten Einstellungs-Menue Java zu aktivieren
vielleicht hilft ein Screenshot, der Folgende ist AOO 4.1.2 unter Windows
Optionen-Java.gif
Optionen-Java.gif (38.36 KiB) 515 mal betrachtet
Du musst wie folgt klicken:
-links oben auf das + vor OpenOffice um die Unterpunkte zu entfalten
-dann auf OpenOffice um diesen Punkt zu fokussieren
-dann 12 mal Pfeil-runter-Taste

und dann rechts den bei dir nicht ausgewählten Optionspunkt und unten die vierte Schaltfläche von links.

Gruß
Stephan

Gast Peter

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von Gast Peter » Do, 05.01.2017 15:54

Aus dem englischen Forum:
https://forum.openoffice.org/en/forum/v ... 17&t=73293
Dort half Ausschalten der Verwendung der Systemschriften.
Etwas fummelig, weil du nicht viel siehst, aber machbar.
Ich kann dir leider keinen Screenshot zur Orientierung hochladen, vielleicht ist jemand anders so nett?

Hier findest du sonst eine Abbildung aus einer älteren OO-Version:
http://www.openoffice.org/de/doc/oooaut ... ichten.pdf
Seite 10 Abbildung 4

Viel Glück

Stephan
********
Beiträge: 9671
Registriert: Mi, 30.06.2004 19:36
Wohnort: nahe Berlin

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von Stephan » Do, 05.01.2017 17:48

so hier sieht die Dialogseite mit der Option für Systemschrift aus:
Optionenen-Systemschrift.gif
Optionenen-Systemschrift.gif (47.19 KiB) 481 mal betrachtet

jm@erdnah.de
Beiträge: 5
Registriert: Mi, 04.01.2017 09:36

Re: Mac - 4.1.3 - Beschriftungen fehlen

Beitrag von jm@erdnah.de » Do, 05.01.2017 18:36

Hallo Stephan, Hallo Peter,

Wow. Das wars. Ich sehe Texte!

Also den Ausschlag hat der Haken "Systemschriftart verwenden" im Menuepunkt "Ansicht" gegeben. Ich habe den deaktiviert, habe dann den Rechner einmal neu gestartet und sehe nun Texte.

Wenn ich, um den Vorgang zu verifizieren, den Haken wieder setzen möchte, stürzt OpenOffice ab und wird beendet. Hier springt der Affe also ins Wasser.

Stephan, vielen Dank für euren Einsatz! Ich hatte mich schon das hässliche Microsoft-Ding benutzen und fluchen sehen... Daumen hoch!

Gruß, jörg

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast