Externes Formular "vergisst" Verbindung zu Datenbank

Datenbanklösungen mit AOO/LO

Moderator: Moderatoren

bubuca
Beiträge: 1
Registriert: Fr, 19.01.2018 16:52

Externes Formular "vergisst" Verbindung zu Datenbank

Beitrag von bubuca » Fr, 19.01.2018 17:08

Hallo :)

ich mache gerade meine erste komplexere Datenbank mit Base(Libre Office V 5.4.3.2 (x64) auf Win 10) und viele Beiträge haben mir schon geholfen. Aber jetzt stehe ich vor einem Problem, über das ich noch nichts gelesen habe. Für die DB wollte ich ein externes Formular erstellen, damit die Datenbank nicht immer geöffnet werden muss.

Die Datenbank ist angemeldet, die Quelle bei Formulareigenschaften auch auf die Datenbank eingestellt. Das funktioniert. Aber wenn das Formular dann geschlossen wird und erneut geöffnet wird, von meinem oder von einem anderen PC aus, ist die Verbindung bei den Formulareigenschaften weg und man kann auch keine Einträge mehr machen.

Gibt es eine Einstellung, dass die Datenbank mit dem Formular verbunden bleibt oder muss diese Verbindung immer neu eingestellt werden?

Was muss ich beachten?

Danke und Gruß

RobertG
*******
Beiträge: 1681
Registriert: Fr, 13.04.2012 19:28
Kontaktdaten:

Re: Externes Formular "vergisst" Verbindung zu Datenbank

Beitrag von RobertG » Fr, 19.01.2018 19:04

Hallo bubuca,

das ist dieser Bug:
https://bugs.documentfoundation.org/sho ... ?id=114596

Da hilft im Moment nur, eine LO-Version vor 5.1 oder AOO zu nutzen. Das Schlimme ist nämlich nicht nur, dass die einmal gemachten Einstellungen anschließend wieder weg sind - die eingetragenen Daten fehlen auch noch.

Gruß

Robert

hylli
*******
Beiträge: 1641
Registriert: Mi, 22.02.2006 19:37

Re: Externes Formular "vergisst" Verbindung zu Datenbank

Beitrag von hylli » Fr, 19.01.2018 20:43

Kein Wunder, dass es mir die Tage mit LibreOffice 5.4.x nicht gelingen wollte. Leider bin ich geschäftlich an diese Version gebunden, zumindest wenn ich solche Lösungen für die Allgemeinheit zur Verfügung stellen will.

Hoffentlich wird das zeitnah mit einer der kommenden Version 5.4.x oder spätestens mit 6.x gefixt.

Hylli
Ein Dankeschön für eine Lösung tut nicht weh!
Wer eine Lösung selbst findet, sollte die für die Nachwelt auch posten!

Geschäftlich: LibreOffice 5.1.x ("Still") unter Windows 7 32/64bit
Privat: LibreOffice 5.x unter Linux Mint 18.x Cinnamon 64bit u. Arch Anywhere "Mate"

RobertG
*******
Beiträge: 1681
Registriert: Fr, 13.04.2012 19:28
Kontaktdaten:

Re: Externes Formular "vergisst" Verbindung zu Datenbank

Beitrag von RobertG » Mi, 31.01.2018 18:58

Hallo *,

der Bug ist jetzt zumindest schon einmal für die künftige LO 6.1.0 behoben:
https://bugs.documentfoundation.org/sho ... ?id=114596
... und auch in allen anderen zukünftigen Versionen. Für LO 6.0.0 hat es nicht mehr gereicht, aber LO 6.0.1 und LO 5.4.6 sollten in dem Bereich wieder funktionieren.

Gruß

Robert

Antworten