XP merkt sich Dateityp nicht ... gelöst

spezielle Probleme mit AOO/LO unter Windows

Moderator: Moderatoren

schluckab
Beiträge: 2
Registriert: Fr, 14.05.2010 13:27

XP merkt sich Dateityp nicht ... gelöst

Beitrag von schluckab » Fr, 14.05.2010 13:34

Servus Ladies and Gentlemen,

vorab folgender Hinweis:
Ich habe bereits gegoogelt, jedoch ohne eine Lösung gefunden zu haben. Ich bitte um Nachsicht, falls dieses Problem in diesem Forum bereits behandelt worden sein sollte. Für komplexe Suchmethoden bin ich halt zu blöd. Aber in welchem Lichte könnte ein ITler erstrahlen, wenn er keine DAU um sich herum hätte … ;)

Ich habe Probleme mit OOo 3.2 unter Windows XP SP3

Benutzer mit eingeschränkten Rechten werden OOo-Dateien (.odt/.ods und vermutlich auch die anderen Dateitypen) im Windows-Explorer nicht korrekt angezeigt (Icon). Den Benutzern mit eingeschränkten Rechten ist es nicht möglich, im Explorer OOo-Dateien mit Doppelklick zu öffnen. Sofern die Benutzer die Dateien nicht aus OOo heraus öffnen, läuft jedes Mal dieses Prozedere ab.

- Fenster „Die folgende Datei kann nicht geöffnet werden“
- Auswahl: „Programm aus einer Liste auswählen“
- Fenster: „Wählen Sie das Programm, das zum Öffnen dieser Datei geöffnet werden soll“
- OOo wird zwar als empfohlenes Programm angezeigt, nicht jedoch Writer oder Calc
- Das Häkchen „Dateityp immer mit dem ausgewählten Programm öffnen“ ist gesetzt, aber XP merkt sich die Zuordnung nicht

Folgende Maßnahmen bisher erfolglos durchgeführt:
- Zuordnung in MS-Explorer über Extras/Odneroptionen/Dateitypen
- Deinstallation, Bereinigung der Registry mit diversen Tweak-Tools mit anschließender Neuinstallation

Wenn ich dem eingeschränkten User Adminrechte zuweise funktioniert alles wunderbar. Sobald ich die Rechte einschränke habe ich o.g. Prob. Auch Hauptbenutzerrechte reichen nicht aus, um die Dateien mit Doppelklick zu öffnen. Das funzt ausschließlich mit Adminrechten.

Auf einem zweiten Rechner (gleiches OS, gleich OOo-Version) funzt alles ohne Probs! Meiner Ansicht nach liegt das Problem in der Registry begraben. Aber wo? Mit meinen bescheidenen Fähigkeiten habe ich die Registry durchforstet und beide Rechner miteinander verglichen. Ich finde den Fehler nicht :-(

Problemlösung eilt nicht, trotzdem schon mal vielen Dank für Interesse und Hilfe vorab ...
Zuletzt geändert von schluckab am So, 30.05.2010 13:07, insgesamt 1-mal geändert.

Drachen
*****
Beiträge: 223
Registriert: Do, 27.10.2005 19:05

Re: XP merkt sich Dateityp nicht ...

Beitrag von Drachen » Sa, 15.05.2010 20:15

Hallo,

Windows merkt sich also die Enstellungen des Benutzers nicht. Wo liegen die Userprofiles, im Netz oder lokal? Mittlerweile nur noch selten genutzt sind auch sog. mandantory profiles, welche Änderungen durch User explizit verwerfen beim Abmelden.

Wenn der Admin angemeldet ist, prüfe doch mal in der Registry (Zweig HKEY_Classes-Root), ob dort überhaupt die Einträge für OOo gesetzt sind, also
die ganzen Pfade wie beispielsweise HKEY_CLASSES_ROOT\.odt und die jeweils "korrespondierenden" wie HKEY_CLASSES_ROOT\opendocument.WriterDocument.1 usw. usw.
Dieselben Einträge finden sich normalerweise nochmal unter HKEY_LOCAL_MACHINE (HKLM), dort dann unter HKLM\SOFTWARE\Classes\, sind diese im System zu finden?
Als nächstes prüfe die Zugriffsberechtigungen auf eben diese Zweige und untergeordneten Einträge, womöglich fehlt der Gruppe der normalen Benutzer ja die Leseberechtigung. Ich denke aber eher dass die Pfade/Einträge einfach fehlen, womöglich ist da mal wieder jemand mit einem dieser "tollen" Aufräumprogramme drüber gesaust o.ä.
Und schließlich kannst Du, nur für alle Fälle, noch die Mitgliedschaft der betroffenen Account in berechtigungsgruppen prüfen, zumindest die "Benutzer" sollten es schon sein - da Du aber explizit die Hauptbenutzer erwähnst, ist der Punkt wohl eher unwahrscheinlich und nicht relevant.

Dein Problem kann ich nicht so fix lösen, aber falls die bisher geäußerten Gedanken nicht hilfreich sind, gibt es ja evtl. eine Möglichkeit, per Autostart jedesmal die Zuordnung für die verschiedenen OOo-Files ins System zu schreiben, Du müsstest sie halt nur einmalig alle exportieren mit einem Admin-Account und zusammen fassen und die Pfade anpasen auf einen, wo der normale kleine User Schreibrechte hat (der HKCR-Zweig wird teilweise in die HKCU-Struktur hinein "gespiegelt" und ließe sich dort m.E. auch um fehlende Einträge ergänzen, also unter HKCU\Software\Microsoft\Windows\SurrentVersion\Explorer\FileExts\ o.ä.

Alternativ wäre mal zu prüfen, ob die Installation von OOo generell nicht etwas unsauber ist, womöglich gabs ja dabei ein Problem und OOo hat seine Dateien nicht korrekt registriert, macnhe Virenscanner hauen hier dazwischen und blockieren oder Firewalls wollen das System schützen.

Ich hoffe, dass ich hilfreiche Ideen beitragen konnte.

MfG
Drachen

schluckab
Beiträge: 2
Registriert: Fr, 14.05.2010 13:27

gelöst ... vielen Dank

Beitrag von schluckab » So, 30.05.2010 13:07

Hallo Drachen,

vielen Dank für die Hilfe.

Unter HKEY_CLASSES_ROOT waren die Berechtigungen nicht gesetzt.

Herzliche Grüße

Nini3100
Beiträge: 2
Registriert: Do, 11.11.2010 11:43

Re: XP merkt sich Dateityp nicht ... gelöst

Beitrag von Nini3100 » Do, 11.11.2010 11:52

Ich habe genau dasselbe Problem mit den Dateitypen von OOo, jedes mal, wenn ich ein neues Tabellen-Dokument abspeicher, fehlt das Calc-Icon.
Jetzt isses so, dass ich keine Ahnung hab, wo ich die Registry bei Windows XP finden kann.
Könnte mir das vllt jemand sagen, damit ich alle Berechtigung richtig einstellen kann?

lg
Nini

pmoegenb
********
Beiträge: 4331
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: XP merkt sich Dateityp nicht ... gelöst

Beitrag von pmoegenb » Do, 11.11.2010 12:32

Nini3100 hat geschrieben:Ich habe genau dasselbe Problem mit den Dateitypen von OOo, jedes mal, wenn ich ein neues Tabellen-Dokument abspeicher, fehlt das Calc-Icon.
Jetzt isses so, dass ich keine Ahnung hab, wo ich die Registry bei Windows XP finden kann.
Könnte mir das vllt jemand sagen, damit ich alle Berechtigung richtig einstellen kann?
Du bist also auch ein Benutzer mit eingeschränkten Rechten. Wenn nicht, hast Du nicht dasselbe Problem.

- Öffne den Windows-Explorer und markiere ein Calc-Dokument
- Drücke die rechte Maustaste und wähle die Optionen Öffnen mit/Programm auswählen...
- Aktiviere im Fenster Öffnen mit die Checkbox Dateityp immer mit dem ausgewählten Programm öffnen
- Wähle OpenOffice.org Calc aus. Wenn das Programm im Fenster nicht angezeigt wird, musst Du auf den Button Durchsuchen klicken und das Programm auf der Festplatte suchen
Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

Gast

Re: XP merkt sich Dateityp nicht ... gelöst

Beitrag von Gast » Do, 11.11.2010 12:58

Problem mit den Dateitypen von OOo, jedes mal, wenn ich ein neues Tabellen-Dokument abspeicher, fehlt das Calc-Icon
Haben Deine Dateien denn überhaupt eine entsprechende Dateinamenerweiterung/Dateityp/Dateiendung?
Ist im Speichern-Dialog der Haken bei "Automatische Dateinamenerweiterung" drin?

Nini3100
Beiträge: 2
Registriert: Do, 11.11.2010 11:43

Re: XP merkt sich Dateityp nicht ... gelöst

Beitrag von Nini3100 » Fr, 12.11.2010 19:41

Gast hat geschrieben:
Ist im Speichern-Dialog der Haken bei "Automatische Dateinamenerweiterung" drin?
Vielen vielen Dank für den Tipp, Gast :)
Der Fehler lag beim nicht gesetzten Haken bei der automatischen Dateinamenerweiterung, den ich nun gesetzt habe und es jetzt wunderbar klappt mit dem Icon :D

lg
Nini

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste