das leidige "schreibgeschützt"

spezielle Probleme mit AOO/LO unter Windows

Moderator: Moderatoren

networm
Beiträge: 2
Registriert: Mi, 10.11.2010 14:12

das leidige "schreibgeschützt"

Beitrag von networm » Mi, 10.11.2010 14:35

Wir verwenden in der Firma Openoffice in der jeweils neusten Version auf Windows-PCs. Als Server dient ein ReadyNAS von Netgear. Nachdem nun wiederum ein neuer Nutzer angelegt und ein neuer Share auf dem NAS eingerichtet wurde, gibt es wieder Problem mit dem Öffnen der Dateien...

Alle Nutzer auf dem neuen Share auf dem NAS haben komplette Rechte zum Lesen und Schreiben. Neue Dateien können beliebig erstellt und geändert werden.

OpenOffice-Dateien, die auf diesen Share kopiert wurden (im speziellen Fall Dateien der Tabellenkalkulation), lassen sich öffnen - in der farbigen Zeile oben im Fenster des Openoffice erscheint hinter dem Dateinamen jedoch der Eintrag "schreibgeschützt" in Klammern - die Dateiattribute der Datei im Ordner des NAS weisen jedoch keinen Schreibschutz auf. Wird die Datei in einen anderen Ordner im gleichen Share kopiert, kann man diese normal und ohne Schreibschutz öffnen. Es sind aber zu viele Dateien, dass man es den Mitarbeitern zumuten könnte, dies generell so zu handhaben. Lockdateien sind übrigens keine vorhanden - diese erscheinen ganz normal, wenn die Datei geöffnet wird und werden nach dem Schliessen der Datei auch wieder automatisch gelöscht.

Ich habe jetzt schon so viel dazu gelesen. Vorweigend betrifft dies jedoch Nutzer von Openoffice unter Linux. Das NAS ist zwar Linux, aber die Rechtevergabe dort ist absolut ok und es gibt mit keinem anderem Programm ausser dem Openoffice diese Probleme auf diesem Share.

Wo liegt hier der Hase im Pfeffer???

pmoegenb
********
Beiträge: 4331
Registriert: Di, 22.06.2004 12:02
Wohnort: 71134 Aidlingen
Kontaktdaten:

Re: das leidige "schreibgeschützt"

Beitrag von pmoegenb » Mi, 10.11.2010 15:08

networm hat geschrieben: OpenOffice-Dateien, die auf diesen Share kopiert wurden (im speziellen Fall Dateien der Tabellenkalkulation), lassen sich öffnen - in der farbigen Zeile oben im Fenster des Openoffice erscheint hinter dem Dateinamen jedoch der Eintrag "schreibgeschützt" in Klammern - die Dateiattribute der Datei im Ordner des NAS weisen jedoch keinen Schreibschutz auf. Wird die Datei in einen anderen Ordner im gleichen Share kopiert, kann man diese normal und ohne Schreibschutz öffnen.
Dies spricht eigentlich dafür, dass die Rechte am Verzeichnis beim kopieren nicht auf die einzelnen Objekte vererbt wurden. Hast Du das an einem einzelnen Objekt schon geprüft ?
Gruß

Peter
---------------------------------------------------------------------------
Windows 7 Prof. 64-bit SP1, LibreOffice 4.3.6.2 und AOO 4.1.1

networm
Beiträge: 2
Registriert: Mi, 10.11.2010 14:12

Re: das leidige "schreibgeschützt"

Beitrag von networm » Mi, 10.11.2010 16:07

Bin ja schon seit heut morgen am forschen - kurioserweise konnte ich testhalber neue Textdateien von einem Benutzer aus erstellen - alles ohne Probleme. Der Benutzer konnte aber keine ods-Dateien erstellen. Das hab ich vorhin auch grad gemerkt. Alle Einstellungen im Server waren korrekt, Server und anschl. Systeme neu gebootet. Ursache waren dann aber scheinbar doch die Besitzrechte im ReadyNASNV+ von Netgear. Dort gibt es zu den Shares dann noch eine Option, in der man festlegen kann, das die Besitzrechte, so wie diese festgelegt wurden, auch wirklich so übernommen werden sollen... Klingt sehr kurios - aber seitdem ich diesen Haken gesetzt habe läuft es. Was Netgear da gemacht hat ist mir unklar. Wenn ich vorher die Einstellungen ändere, dann auf übernehmen gehe, das System rödelt und mir dann mitteile, die Einstellungen wurden korrekt übernommen, das System danach auch noch mal gebootet wurde - was soll man dann noch tun. Wozu brauche ich dann diese Option???

Auf jeden Fall läuft es jetzt!

Und es lag nicht am OpenOffice!!!

Gast

Re: das leidige "schreibgeschützt"

Beitrag von Gast » Mi, 10.11.2010 16:51

Ursache waren dann aber scheinbar doch die Besitzrechte im ReadyNASNV+ von Netgear.
Und es lag nicht am OpenOffice!!!
Kann man jetzt auch ruhig ein bisschen hervorheben, finde ich ...

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 8 Gäste