Wiederherstellung lässt mich im Stich

Setup und Komponenten-übergreifende Probleme.

Moderator: Moderatoren

stevenson
Beiträge: 6
Registriert: Do, 07.06.2018 18:47

Wiederherstellung lässt mich im Stich

Beitrag von stevenson » Do, 07.06.2018 18:55

Hallo zusammen,

ich habe Schwierigkeiten bei der Wiederherstellung eines - ihr ahnt es bereits - wichtigen Dokumentes. Open Office nennt mir als Fehlerbericht folgendes:

Fehler beim Laden des BASIC des Dokuments file:///User/Benutzer/Library/Application%Support/OpenOffice/4/user/basic/dialog.xlc/:
Allgemeiner Fehler. Allgemeiner Ein-/Ausgabefehler.

Mein Betriebssystem ist OS X.

Dieses Problem hatte ich bisher nie und weiß nicht, was ich tun soll. Bin dankbar für eure Hilfe!!

LG Steven

freedom
********
Beiträge: 2176
Registriert: Do, 16.08.2007 15:12

Re: Wiederherstellung lässt mich im Stich

Beitrag von freedom » Do, 07.06.2018 19:30

Hallo Steven,

https://de.openoffice.info/viewtopic.php?t=65352
Hilft dir das?

Dein Problem findet sich mehrfach (nicht nur) in diesem Forum.
[Suchfunktion oben rechts :lol: ]

stevenson
Beiträge: 6
Registriert: Do, 07.06.2018 18:47

Re: Wiederherstellung lässt mich im Stich

Beitrag von stevenson » Do, 07.06.2018 20:56

freedom hat geschrieben:
Do, 07.06.2018 19:30
Hallo Steven,

https://de.openoffice.info/viewtopic.php?t=65352
Hilft dir das?

Dein Problem findet sich mehrfach (nicht nur) in diesem Forum.
[Suchfunktion oben rechts :lol: ]
Nein, leider bezieht sich das auf Windows. Ich nutze Mac : ( Trotzdem danke!

freedom
********
Beiträge: 2176
Registriert: Do, 16.08.2007 15:12

Re: Wiederherstellung lässt mich im Stich

Beitrag von freedom » Do, 07.06.2018 21:11

Ich weiß, dass du kein Windows hast, der Pfad unterscheidet sich.

Den Pfad zu deinem Benutzerverzeichnis hast du ja genannt,
„/OpenOffice/4/user/basic/dialog.xlc/“ ist bei dir auch drin.

Es geht ja um von mir jetzt unterstrichene Datei.
Die Lösung aus dem Windows-Thread ist auch bei dir anwendbar.

stevenson
Beiträge: 6
Registriert: Do, 07.06.2018 18:47

Re: Wiederherstellung lässt mich im Stich

Beitrag von stevenson » Do, 07.06.2018 21:59

Ok - nachdem ich jetzt die versteckten Ordner beim Mac kennengelernt habe - grrr! - konnte ich den Pfad zwar finden, leider liegt dort am Ende aber kein dialog.xlc

Und wo sich das Benutzerverzeichnis findet, erschließt sich mir auch nicht...

*verzweifelt*

nikki
******
Beiträge: 622
Registriert: Do, 05.03.2015 10:42

Re: Wiederherstellung lässt mich im Stich

Beitrag von nikki » Do, 07.06.2018 22:19

stevenson hat geschrieben:
Do, 07.06.2018 21:59
Und wo sich das Benutzerverzeichnis findet, erschließt sich mir auch nicht...
Vermutlich unter /Users/<Benutzername>/Library/Application Support/OpenOffice/4/user.

Wichtig: Diese Verzeichnisse sind versteckt. Unter Lion muss man im Finder bei gedrückter Options-Taste unter "Gehe zu" den Ordner "Library" sichtbar machen, um diesen aufrufen zu können.

siehe dazu http://wiki.documentfoundation.org/UserProfile/de, Der Inhalt kann analog auch bei OpenOffice angewandt werden.
Gruß

---------------------------------------------------------
Win.10 Prof. 64-bit, AOO 4.1.5, LO 6.1.0 (x64)

stevenson
Beiträge: 6
Registriert: Do, 07.06.2018 18:47

Re: Wiederherstellung lässt mich im Stich

Beitrag von stevenson » Do, 07.06.2018 22:40

Danke nikki!

Hab das Benutzerverzeichnis gefunden und umbenannt. Die Fehlermeldung erscheint leider immer noch, auch nach Neustart.

freedom
********
Beiträge: 2176
Registriert: Do, 16.08.2007 15:12

Re: Wiederherstellung lässt mich im Stich

Beitrag von freedom » Do, 07.06.2018 22:42

Und wo sich das Benutzerverzeichnis findet, erschließt sich mir auch nicht...
Das steht in der Fehlermeldung in deinem ersten Beitrag.
Benutzerverzeichnis von OpenOffice darin ist -->.... /OpenOffice/4/user

stevenson
Beiträge: 6
Registriert: Do, 07.06.2018 18:47

Re: Wiederherstellung lässt mich im Stich

Beitrag von stevenson » Do, 07.06.2018 22:58

Hab´s gefunden und umbenannt. Hat nur leider nicht geholfen. Unter dem Pfad finde ich auch kein dialog.xlc sondern nur script.xlc.

freedom
********
Beiträge: 2176
Registriert: Do, 16.08.2007 15:12

Re: Wiederherstellung lässt mich im Stich

Beitrag von freedom » Fr, 08.06.2018 00:23

Hallo Steven,
finde ich auch kein dialog.xlc
Findest auch nicht mit Mac-Suchfunktion?

Dann schau dir noch einmal den Windows-Beitrag
und nimm die zuerst beschriebene Lösung.

Kopiere dialog.xlc aus:
<AOO-Installationsverzeichnis>/presets/basic/dialog.xlc

und füge es ein in:
User/Benutzer/Library/Application%Support/OpenOffice/4/user/basic

! Dabei soll OO komplett geschlossen sein!
(Hoffe, vor dem Umbenennen des Benutzerverzeichnisses hattest du ebenfalls OO geschlossen)

stevenson
Beiträge: 6
Registriert: Do, 07.06.2018 18:47

Re: Wiederherstellung lässt mich im Stich

Beitrag von stevenson » Fr, 08.06.2018 08:58

Nein, leider kein Erfolg bei der Suche : ( Weder dialog.xlc noch die presets im Installationsverzeichnis. Wie vom Erdboden verschluckt. Ich werde die Datei wohl oder übel als verloren abhaken.

Vielen Dank für eure Hilfe!!!

Benutzeravatar
Faol
***
Beiträge: 76
Registriert: Di, 26.01.2016 21:18

Re: Wiederherstellung lässt mich im Stich

Beitrag von Faol » Fr, 08.06.2018 13:04

Hallo,
Stevenson hat geschrieben:Weder dialog.xlc noch die presets im Installationsverzeichnis. Wie vom Erdboden verschluckt. Ich werde die Datei wohl oder übel als verloren abhaken.
Das ist nicht erforderlich!
Der Ordner Basic enthält nur Daten, wenn Du über Makros und Makrobibliotheken verfügst.
Zur Datei "dialog.xlc" gehört auch noch die Datei "dialog.xlb". Beides sind XML-Dateien die diverse Verweise enthalten.
Nun kann es sein, dass Dein Dokument Makros enthält und versucht im Ordner Basic Daten zu finden.

Erstelle einfach mal eine leere Makrobibliothek. Dann wird der Ordner Basic mit Daten gefüllt.
Aber bevor Du dieses machst, solltest Du den USER-Ordner kopieren und unter einem anderen Namen abspeichern.
z.B. USER-20180608
Der USER-Ordner "User" sollte aber erhalten bleiben, sonst gehen Deine benutzerdefinierten Einstellungen verloren!
  1. MENÜ Extras → Makros → Makros verwalten
  2. Im sich öffnenden Fenster klickst Du auf „Verwalten“.
  3. Im nächsten Fenster wählst Du das Register „Bibliotheken“.
  4. Jetzt den Button „Neu“ anklicken und
  5. im darauffolgenden Fenster einen Namen eingeben. Statt „Library1“, z.B. „MeineMakros“.
  6. Alle Verwaltungsfenster schließen.
  7. AOO beenden und neustarten.
  8. Nun versuche Dein Dokument zu öffnen.
Was passiert, d.h. Wenn Fehlermeldung, wie lautet diese?

Gruß
Faol
⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒⇒
Win.10 Prof. (x64) • AOO 4.1.5
⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐⇐

Antworten