Lineare Interpolation

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

CheVeyo20
Beiträge: 3
Registriert: Sa, 28.07.2012 14:55

Lineare Interpolation

Beitrag von CheVeyo20 » Sa, 11.04.2015 21:08

Hi Zusammen :)

ich sitz jetzt schon seit Stunden an wahrscheinlich einer total einfachen Sache :P

Ich habe eine Datenreihe x und eine Datenreihe y. Die Datensammlung als Ganze ist nicht linear, als keine Regressionsgerade vorschlagen ;) Es ist aber erlaubt, zwischen zwei Werte zu interpolieren!

Ich habe auch eine Excel Variante gefunden:

http://www.excelformeln.de/formeln.html?welcher=373

Ich habe das mit dem Befehl probiert:

=INDEX(B2:B11+(D1-A2:A11)*(B3:B12-B2:B11)/(A3:A12-A2:A11);VERGLEICH(D1;A2:A11;1))

Bekomme aber einen #Wert Fehler! Ich vermute wegen dem 1. Parameter von Index, da Excel Bereichoperationen erlaubt und Calc nicht.
Es müssen viele Werte interpoliert werden und ich kann nicht für jeden Wert Hilfswerte erschaffen!
D.h. die Lösung muss zwingend exakt eine Zelle belegen (also der gesuchte Y Wert muss zurückgegeben werden)

Hat jmd eine coole Idee für mich?

viele Grüße

CheVeyo20

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Lineare Interpolation

Beitrag von Karolus » Sa, 11.04.2015 21:37

Hallo

Wenn die x-werte in Spalte A aufsteigend sortiert sind:

Code: Alles auswählen

=SCHÄTZER(D1;VERSCHIEBUNG(A1;VERGLEICH(D1;A1:A10)-1;1;2);VERSCHIEBUNG(A1;VERGLEICH(D1;A1:A10)-1;0;2))
mit nach D2 ausgelagertem

Code: Alles auswählen

 =VERGLEICH(D1;A1:A10)-1
schrumpft die obere Formel auf:

Code: Alles auswählen

=SCHÄTZER($D$1;VERSCHIEBUNG($A$1;$D$2;1;2);VERSCHIEBUNG($A$1;$D$2;0;2))
AOO4, LO4.3, LO4.4 LinuxMint17.2

CheVeyo20
Beiträge: 3
Registriert: Sa, 28.07.2012 14:55

Re: Lineare Interpolation

Beitrag von CheVeyo20 » So, 12.04.2015 17:42

Hi :)

super danke, klappt prima!

Muss mich jetzt erstmal durchlesen, was deine Funktionen alles bedeuten, aber klappen tut's :D

Karolus
********
Beiträge: 7063
Registriert: Mo, 02.01.2006 19:48
Kontaktdaten:

Re: Lineare Interpolation

Beitrag von Karolus » So, 12.04.2015 19:23

CheVeyo20 hat geschrieben:Hi :)

super danke, klappt prima!

Muss mich jetzt erstmal durchlesen, was deine Funktionen alles bedeuten, aber klappen tut's :D
Sind ja nur drei verschiedene beteiligt, die Dinger von der verlinkten ExcelSeite sind weitaus schwieriger nachzuvollziehen.

Die eigentliche Arbeit erledigt SCHÄTZER mit dem kleinen Handicap "ihm" die passenden Zellbereiche unter zu "SCHIEBEN"

ist folgendes leichter verständlich:

Code: Alles auswählen

=SCHÄTZER(D1;INDEX(B1:B10;D2+{0;1});INDEX(A1:A10;D2+{0;1})) 
enferne dafür die -1 in D2
AOO4, LO4.3, LO4.4 LinuxMint17.2

Antworten