Funktion: Links(a1;3)

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

OOMaBo
Beiträge: 7
Registriert: Mi, 18.07.2018 16:09

Funktion: Links(a1;3)

Beitrag von OOMaBo » Mo, 23.07.2018 16:31

Hallo,


ich habe hier etwas, dass mich zweifeln lässt:

Ich kann einen Zelleninhalt mit der Funktion „Links“ beschneiden, in meinem Fall die ersten 3 Buchstaben/Zahlen.

Das klappt super, in manchen Zellen stehen jetzt zahlen, in anderen Buchstaben, manchmal auch kombiniert, je nachdem was in der ursprungszelle steht.

Nun möchte ich, dass nur bei einem bestimmten „Ergebnis“ eine Berechnung durchgeführt wird, was auch funktioniert, nur passiert folgendes:

Es geht um Zahl 123, taucht diese in der Spalte auf, soll gerechnet werden 123*2, ansonsten soll die Zelle leer sein.

Solange in der Zelle eine Zahl steht, klappt das, wirft die Funktion aber Buchstaben aus, oder Buchstaben und zahlen kombiniert, als 3tb oder ew7... dann kommt ein Fehler.

Ich habe es probiert mit „wert“ und ohne...


Wie kann ich die Buchstaben also mit ausblenden?

OOMaBo
Beiträge: 7
Registriert: Mi, 18.07.2018 16:09

Re: Funktion: Links(a1;3)

Beitrag von OOMaBo » Mo, 23.07.2018 16:33

Oh mein Gott...

Ich habe die „“ vergessen... es muss die 123 in „“ sein, dann passt es...

Mondblatt24
*****
Beiträge: 220
Registriert: So, 14.05.2017 16:11

Re: Funktion: Links(a1;3)

Beitrag von Mondblatt24 » Mo, 23.07.2018 16:41

Hallo,
trotz dürftiger Angaben(deine Formel) schieße ich mal "ins Blaue".

Code: Alles auswählen

WENN(ISTFEHLER(LINKS(A1;3)*2);"";LINKS(A1;3)*2)
MfG Peter
Win.10(x64)__ LO 5.4.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

ChristianAC_

Re: Funktion: Links(a1;3)

Beitrag von ChristianAC_ » Mo, 23.07.2018 17:16

Hallo OOMaBo,

'glaskugelabhängig ;-)' Variante 2:
=WENN(NICHT(LINKS(A1;3)="123");"";A1*2)

Schönen Gruß, ChristianAC

Antworten