Spalten berechnen

Das Tabellenkalkulationsprogramm

Moderator: Moderatoren

jef0815
**
Beiträge: 22
Registriert: Fr, 01.04.2016 11:48

Spalten berechnen

Beitrag von jef0815 » Di, 08.01.2019 15:49

Hallo Gemeinde,
ich erstelle eine Tabelle mit diversen Ausgaben und möchte verschiedene Berechnungen ausführen. Also z.B. Verbrauch pro 100 km in Liter. Da berechne ich die Differenz des km-Wertes mit der Zelle darüber. Ist diese Zelle aber leer funktioniert die Berechnung natürlich nicht. Gibt es eine Möglichkeit die leeren Zellen zu überspringen? Besser zu verstehen was ich meine ist in der Anlagedatei ersichtlich.
Dateianhänge
kfzkosten_test.ods
(14.91 KiB) 21-mal heruntergeladen

paljass
******
Beiträge: 689
Registriert: Do, 25.10.2012 07:25

Re: Spalten berechnen

Beitrag von paljass » Di, 08.01.2019 16:15

Hi,
in e3:

Code: Alles auswählen

=WENN(ISTLEER(B3);"";B3-MAX($B$2:B2))
und nach unten kopieren.
In den anderen Zellen kannst du auch mit =WENN(ISTLEER(B3);"";... arbeiten.

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

Mondblatt24
*****
Beiträge: 286
Registriert: So, 14.05.2017 16:11

Re: Spalten berechnen

Beitrag von Mondblatt24 » Di, 08.01.2019 17:51

Hallo,
andere Formel, gleiches Ergebnis

Code: Alles auswählen

=WENN(B3="";"";B3-VERWEIS(B3;$B$2:B2))
Gruß Peter
Win.10(x64)__ LO 6.0.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

jef0815
**
Beiträge: 22
Registriert: Fr, 01.04.2016 11:48

Re: Spalten berechnen

Beitrag von jef0815 » So, 13.01.2019 16:52

Hallo,
die beiden Formeln von euch funktionieren erst einmal, aber wenn ich z.b. in Zeile 13 einen km-Stand eingebe (auch bei ausgetauschten Teilen wichtig) dann wird das Ergebnis bei Verbrauch und Kosten verfälscht. Ich hatte ursprünglich versucht die km-Differenzen direkt in die Formeln einfließen zu lassen, aber das ist mir nicht gelungen. Deshalb die Hilfsspalte Strecke.

Gruß
Jürgen

paljass
******
Beiträge: 689
Registriert: Do, 25.10.2012 07:25

Re: Spalten berechnen

Beitrag von paljass » Mo, 14.01.2019 08:24

Ja mei,
dann fragst du halt ab, ob die Spalte C leer ist oder nicht ==WENN(ISTLEER(C3);...

Gruß
paljass
EDV ist wie U-Boot fahren - machst du ein Fenster auf, fangen die Probleme an.

jef0815
**
Beiträge: 22
Registriert: Fr, 01.04.2016 11:48

Re: Spalten berechnen

Beitrag von jef0815 » Gestern 17:03

Hallo,
Danke für eure Mühe und Lösungsvorschläge. Angehängt ist eine Datei die ich neu gebastelt habe. Und zwar habe ich mehrere Hilfsspalten benutzt, um die aktuelle Zeile (Spalte K), die Zeile in der der letzte Eintrag in Spalte C steht (Spalte L) und die Spalte M mit den Werten für die Berechnung von Spalte E. Das Ergebnis ist in den Spalten E,G und H nun korrekt. Sehr wahrscheinlich gibt es hierbei eine elegantere Lösung, aber so funktioniert es ja auch. Das Hauptproblem war, wie kriege ich die richtigen Zellen für die Berechnung heraus, wenn es eine oder mehrere Leerzellen gibt.
Dateianhänge
kfzkosten_test1.ods
(16.96 KiB) 4-mal heruntergeladen

Mondblatt24
*****
Beiträge: 286
Registriert: So, 14.05.2017 16:11

Re: Spalten berechnen

Beitrag von Mondblatt24 » Gestern 17:49

Hallo,
Das Hauptproblem war, wie kriege ich die richtigen Zellen für die Berechnung heraus, wenn es eine oder mehrere Leerzellen gibt.
die Formel In Spalte J sollte in Deinem Sinne funktionieren.

kfzkosten_test1.1.ods
(23.45 KiB) 4-mal heruntergeladen

Gruß Peter
Win.10(x64)__ LO 6.0.7(x64); AOO Portable 4.1.5
Fragen, die zur Zufriedenheit beantwortet wurden, sollten im Betreff des Eröffnungspost mit dem Zusatz [GELÖST] versehen werden.

Antworten