"Classfactory kann angeforderte Klasse nicht liefern" ?

was sonst nirgends hineinpasst

Moderator: Moderatoren

Delabarquera
*****
Beiträge: 363
Registriert: Do, 24.11.2005 19:17
Wohnort: München

"Classfactory kann angeforderte Klasse nicht liefern" ?

Beitrag von Delabarquera » Mi, 17.04.2019 15:36

Hierzu gibt es eine Voranfrage, spezieller zu OpenOffice, hier:
viewtopic.php?f=1&t=71492&p=280491&sid= ... 3f#p280491

OO 4.1.6
Windows 10. Version 1809

Hallo!

Irgendwann wollte ich unter OO abspeichern, und es kam die Meldung wie im Betreff.

Zwei Fälle konkret:

* OpenOffice speichert nicht mehr mit den Win-Routinen. (Geht nur über eine Einstellung im Programm. Da aber viel umständlicher. Genauere Beschreibung mit dem Link oben, unter Voranfrage.)

* Abbyy FineReader 8 speichert nicht mehr. (Kann inzwischen auch nicht mehr in die Programme, z. B. OpenOffice, senden. Und ruft auch keine Bilder mehr mit "Öffnen" auf. -- Seltsam: Direkt ablegen kann man aber noch Bilddateien für die Erkennung.)

Gefunden:

„ClassFactory kann angeforderte Klasse nicht liefern“ bedeutet, dass die Registrierung/Installation der DDBAC nicht stimmt. Die DLL-Dateien können vorhanden sein, die Werte in der Registry können falsch sein."

* Meine Frage: Helfen da "Registry-Reinigungsprogramme" (gegen die ich was habe, weil sie manchmal mehr kaputtmachen als helfen)? Auf der anderen Seite: Ich möchte, wenn's geht, nicht die Programme neu installieren oder die Festplatte ganz neu aufsetzen ...

Dank schon hier! D.

--

Das Problem scheint sich durch die Windows-Zeiten hindurchzuziehen, wie die Suche zeigt.

https://www.google.com/search?rlz=1C1CH ... vpo05dIylk

--

Gefunden (18.04.2018 17:42) -- Lange her, aber das mit NVidia interessiert mich doch. Treiber-Update führt zu Fehlern?

Antwort auf den Beitrag von MartinHeinrichmeyer am 16 November, 2011

Er läuft wieder problemlos!

1. war der Kombatibilitätsmodus falsch eingestellt
2. der neue Nvida Treiber 285.79 verträgt sich nicht mit WMM. Mit Treiber 8.17.12.5877 läuft alles bestens.

Gruß an Alle fleissigen Helfer.
Matze

--

Delabarquera
*****
Beiträge: 363
Registriert: Do, 24.11.2005 19:17
Wohnort: München

Re: "Classfactory kann angeforderte Klasse nicht liefern" ?

Beitrag von Delabarquera » Fr, 19.04.2019 13:22

Der WinOptimizer von Ashampoo hat schon mal nichts gebracht.

--

Ich sammle weiter die Möglichkeiten:

Ashampoo WIN Optimizer meldet:

Report created: 23.04.2019 18:32:46

Entries found: 3

#0001 Eintrag verweist auf fehlende Datei: C:\Users\[NAME]\AppData\Local\Temp\~nsuA.tmp\Un_A.exe <Typ=8 Delete value "P:\Hfref\jrear\NccQngn\Ybpny\Grzc\~afhN.gzc\Ha_N.rkr" in HKEY_USERS\S-1-5-21-2633621717-2998857093-4177279699-1002\Software\Microsoft\Windows\CurrentVersion\Explorer\UserAssist\{CEBFF5CD-ACE2-4F4F-9178-9926F41749EA}\Count>

#0002 "StorageProviderUriSource Class" verweist auf fehlende Typbibliothek: HKEY_CLASSES_ROOT\TypeLib\{638805C3-4BA3-4AC8-8AAC-71A0BA2BC284} <Typ=46 Delete key HKEY_CLASSES_ROOT\WOW6432Node\CLSID\{9489FEB2-1925-4D01-B788-6D912C70F7F2}\TypeLib>

#0003 "IFileSyncClient11" verweist auf fehlende Typbibliothek: HKEY_CLASSES_ROOT\TypeLib\IFILESYNCCLIENT11 <Typ=51 Delete key HKEY_CLASSES_ROOT\Wow6432Node\Interface\{2B865677-AC3A-43BD-B9E7-BF6FCD3F0596}\TypeLib>

Was heißt das? Wie beheben?

Antworten